0

I keep getting this message when trying to open WMP:
"An internal application error has occurred."

i have checked the registery for both:
regsvr32 jscript.dll
regsvr32 vbscript.dll

both times it gives me DllRegisterServer.......dll succeeded.

and yet it still doesnt work.
i have windows XP home edition. i have windows media player 10 on my computer. someone please help.

4
Contributors
6
Replies
7
Views
11 Years
Discussion Span
Last Post by Chris8082
0

Have you tried to do a system restore to a time it worked?? (This fixs many things)

Good luck......

how is that done? do i need a special program?

0

i updated to windows media player 11 and didnt have a problem since.

0

Hiya,

For anyone still experiencing this problem and re-registering both the jscript and vbscript dll's - the problem may not be the registry. Reconfiguring the 'classes' 260, 261 and 262 still not working? Chances are you have a 'Creative Audigy/Soundblaster Live!' soundcard.

There is a VIRUS out there specifically written for this soundcard and it affects Windows Media Player (WMP and associated programs which us the WMP codecs. It is called MidiDef.exe and is written into the registry rendering the Media Player and soundcard useless even though Winamp and iTunes will play still. Very clever little virus!

To remove it - use 'hijackthis' and it will show up in the logfile. Delete this entry (obviously use backup just in case!) then reboot into safe mode (using F8 to boot into safe mode) and use updated AV software to remove all traces such as Ewido/AVG etc... Norton/Symantec has been known to let this through. I don't like Symantec for this very reason!

Re-install your Media Player and it should complete and work ok... just thought I would pass on this information after weeks of hair pulling out grey matter! Don't thank me, thank the missus for allowing me to persevere!!! :D

Steve

0

I got a couple of suggestions to do with the registry, It had the correct information, I try doing a system restore on it numorous times i kept getting REstart computer then tyr running sysyem restore again. Nothing worked. I'm running XP Professional and WMP 11. I could really use the help.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.