0

Hello, everyone! I joined the forum to find some help for my problem. It seems very similar to that related in this thread -- http://www.daniweb.com/techtalkforums/thread19435.html . I've searched for answers, and the best seems to be found here. :lol:


I did have Norton System Works on this machine, which I have uninstalled using Add/Remove Programs and SymNRT. I am running Windows XP on a Toshiba laptop. I have updated all my drivers and Windows files. I have run a variety of virus checks and spyware software -- including Spybot, Spyware Doctor, Trend Micro's online scans among others. I have tried the MS fix 894391.

The problem occurs only when I boot up. Sometimes, I get the Generic Host Process for Win32 error. If I click to send the report, the information sent is similar to this (I'm not positive about the WER71b0.dir00 part -- the rest looks right):

C:\DOCUME~1\Mark\LOCALS~1\Temp\WER71b0.dir00\svchost.exe.mdmp

C:\DOCUME~1\Mark\LOCALS~1\Temp\WER71b0.dir00\appcompat.txt

szAppName : svchost.exe szAppVer : 5.1.2600.2180 szModName : unknown
szModVer : 0.0.0.0 offset : 00000000


After this message, I get the message that svchost.exe has encountered and error. At this point, the system often hangs. It appears to be writing to a Dr. Watson file. I have had huge Dr. Watson files since this problem began -- once up to 19 Gig. (Yes, Gig). If I can get past this problem, and if I can get online, I have no other problems and the system will run fine until I need to reboot.

I can boot in Windows Safe Mode w/Networking with no problem. If I boot without loading services, I can load fine. However, I've tried taking the services one at a time to see which one is causing the problem, and I have not been able to narrow it down. I think it may be one of the Microsoft services, as I hide those then one by one enable the non-Microsoft services, and I can have problems one time and not the next. Microsoft suggested I create a new user profile, as the old one might be corrupted, but that didn't seem to help. (He also said the proof that it was corrupted was the ~ in the above messages... I thought that was left over from the 8-character file names . . . .)

I've been working with Microsoft technical support with this. They are at the point they want me to backup, reformat the drive, and start fresh. However, I'm not sure I have all my original software disks for my programs, so I'd really like to avoid this if at all possible. Since this seems to have been a problem for over a year now, I'm hoping there have been some new solutions.

I would be truly grateful for any help or suggestions you may offer.

2
Contributors
2
Replies
3
Views
11 Years
Discussion Span
Last Post by chipstone
0

Well, the ultimate solution was to reformat the drive and start again. Sob! It's a pain reinstalling all my programs -- but probably less time consuming than trying to find the problem. I am very curious as to what caused the errors -- it doesn't seem that uncommon.

0

Svchost.exe is utilized by many applications duding windows boot-up with different load parameters.

One of the best things to do is a registry search for all the entries associated with svchost.exe. Most of the entries should be native Windows applications using the program. If you see an entry that svchost.exe is being called upon, and you cannot identify: The original application that created the entry was removed but the registry key exist; that will trigger an error message.

Then svchost.exe will execute an error due to the missing application parameter it was called upon to modify, or load and no longer exist.

I am willing to bet that a Norton System Works registry key exist, and with a svchost.exe parameter present; delete the entry, or entire registry key, and re-boot and see if this sis the culprit.

Always backup, or export the registry key you will be deleting, in case you need it back.

JR

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.