0

I've been having a problem trying to install Windows 7 on a Windows Vista computer. Vista was running fine but wanted to upgrade it, which should be simple. I've done the same thing countless times on other comuters without a problem. So I put the Win 7 install disk in the optical drive and the install fails while windows was "installing files". Ran all the system checks to make sure there was no problem with the optical drive, memory, etc., and the install still stops mid stream telling me there was an I/O error. I can only think it's beause of the [EMS ENABLED] note on the "boot from disk" screen. Research tells me the EMS designation has to do with a machine that's set up as a server...which this one was not, and I haven't yet figured out how to change that. Is it in BIOS? If so, where, and how do I get to it?

3
Contributors
3
Replies
27
Views
7 Months
Discussion Span
Last Post by JenniferArden
1

I'll defer EMS to Dr. Google.

OK, I don't have a make and model here so I'll share a recent install that was a HP dv6910us running Vista. Nothing would appear to let it run Windows 7 or beyond, 32 or 64 bit. I had a break and came back to revisit this since the laptop was in otherwise great condition.

So here's what it was. In the BIOS there was a VM setting for the CPU. It may have been VT but the CPU was an older AMD that if you google you learn about VM woes. That was my clue to try it with this disabled in the BIOS. Once that was done, the Windows 7 DVD booted and installed.

Later we (it's an office laptop) used a W7 license then upgraded to W10 64 bit and it ran without any search for drivers. It will live out its days doing web searches and office work.

TL;DR. The make and model matters. Sometimes you have to google a lot and try things.

0

@rproffitt, thanks for your reply. This is an HP Desktop, model a6207c with a 2.3GHz AMD Athlon 64x2 Dual Core Processor, 2.0GB RAM and a 500GB Hard Drive that started life as a 32Bit Windows Vista Home Premium machine. Since my original post I did find a work-around to get my 32 Bit Windows 7 Home Premium installed. Booting from the install disk just wouldn't work, so I tried booting the old Vista, putting the install disk in the drive, then clicking on it to run it in from My Computer. Wouldn't you know, it worked perfectly! I installed the new OS over the old one, and I don't have a clue why or how it worked, but there's no trace of the old [EMS ENABLED] left, during boot or anyplace else. I'm still curious to know "why" I couldn't boot from the disk, but at least I've got my new operating system. I'll be checking with Dr. Google to see what I can learn when time allows. Thanks so much for your interest and help!

1

Compys sure can be temperamental sometimes :|
The other day it was attempted to install Win7 Ultimate x64 on a PC that had Win7 on previously, however re-installing Win7 turned out to be a big obstacle.
Maybe it had something to do with EMS, who knows, however I found a solution on the internet where the Shift+F10 combination saved the install by allowing one to edit the registry and perform a succesful install.

Edited by JenniferArden

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.