I am using Win 10 pro 19043.1110. For some reason earlier this year, the right click /Eject option has gone missing for all my portable usb flash thumb drives showing on My Computer / This PC. It doesn't matter which front or rear ports the usb is connected to (usb2 or usb3). I am talking about small usb flash drives not usb HD mass storage devices.

I have checked in Disk management and quick removal is selected. I have also reinstalled windows keeping files and programmes. Still the same problem. The safely remove usb option is available in the system tray and also under devices and printers but its missing by right clicking the usb in This PC.

Is there any way I can get the right click /Eject option back? Your advice would be appreciated.

Kind regards
Chris

Quick_Removal.JPG

Right_Click_Options.JPG

Recommended Answers

Answered by rproffitt 2,238 in a post from

The thing is that I did check https://www.google.com/search?&q=Right+Click+Eject+Missing and see this has thousands of prior discussions.

We need to always try to fix such ourselves before we start a new discussion. Some get …

Jump to Post
Answered by rproffitt 2,238 in a post from
Answered by rproffitt 2,238 in a post from

I read that differently.

  1. Microsoft changed this last year.
  2. Quick removal appears to not be the option you want if you want to see this menu item.
    Try it the other way. May require a reboot.

So as it stands, Quick removal has changed. I see folk disagreeing …

Jump to Post

All 11 Replies

Rprofitt, thank you very much for your reply. I agree that searching with Google is an excellent way to find solutions. After previously doing a lot of searching on Google and reading through the replies I have not yet found the solution.

The replies found on Google typically mention the following.
1- By default, the right click/Eject option in Windows is only available for small flash thumbdrives and not for usb mass storage devices. - I am aware of that
2- For the right click/Eject option to be available, quick removal must be selected for that particular drive in device manager. - I have done that

It appears that somehow the registry got messed up or Microsoft have removed this feature (unlikely as many Win 10 machines still have it). I don't want to perform a clean install just for this. A repair install hasn't solved the problem.

I suspect the solution is to edit the registry to bring back the right click/eject option. I will keep searching and will report back if I find anything.

Kind regards
Chris

I read that differently.

  1. Microsoft changed this last year.
  2. Quick removal appears to not be the option you want if you want to see this menu item.
    Try it the other way. May require a reboot.

So as it stands, Quick removal has changed. I see folk disagreeing if this was a good thing and what causes what now. To me, this is typical Microsoft messing around and fixing what didn't really need fixing.

Thanks for the suggestion. I tried the other option of "better performance" in disk management and reboted but the right click eject option is still missing. So I reverted back to "Quick removal". I suppose that means as long as copying is not in progress I can just "pull" the drive. However, I always prefer the safely remove option just to be safe.

I will keep trying to find a solution and will post back if I find anything.

Kind regards
Chris

For clarity. What are these USM drives? Sometimes it's a little thing like a typo. Maybe I need to know what USM is?

Thank you for your help. I will look into the possibility of creating a shortcut with an alternative script.

Actually the USB system tray icon ejects fine and also i can right click the device in Control Panel/Devices and Printers right click to eject. It can also be ejected in Win 10 settings/Bluetoth and other devices. But it was previously so much easier just to use right click/eject in This PC. I have no idea why it disapeared. Although some people say they still have it on Win 10, somehow I suspect a windows update has removed it.

USM is a typo and should be USB. I couldn't find a way to correct it after I posted. They are typical small usb thumb drives.

Kind regards
chris

While there are reasons for this menu item to not be present I can only offer guesses given the story so far.

  1. The drive is special in some way. Noted at
    https://answers.microsoft.com/en-us/windows/forum/all/usb-drive-does-not-have-an-eject-option/db7c73c4-2539-4ddd-b602-33e86d28a4f2
    And yes, I've seen these in the wild. You can't expect owners to know what they own to this level of detail.
  2. McAfee and other suites do very odd things like this.
    At least we can eject with the tray, other apps, AutoHotKey and more.
  3. Registry cleaning.
    Now this would seem to be the easy area but in decades I've yet to find a clear path to undoing such changes. Sometimes you get lucky and find which branch to fix but here, nope, haven't found it.
  4. I did find a very specific context menu editor for Windows File Explorer at
    https://www.lopesoft.com/index.php/en/products/filemenutools
    Read item 5 before you dismiss item 4. You did reset W10 but as we know that leaves prior preferences and files behind.
    There's the reason why a shop would wipe the drive and start clean. Or install a new shiny clean SSD and clean install there for a test run.
  5. Your Windows isn't a clean install. The option of keeping files and programmes means the registry didn't get back to stock.

Before going nuclear with a clean install I'd at least try FileMenu Tools and turn off/on all the items in the "Commands of other applications" Drives category.

Thank you very much for the links.

The first link mentions that the right click/eject option is only available for thumb drives which is noted. So I wonder if Windows thinks all my thumb drives are external HD's?

"File Menu Tools" is a neat app. Thanks for sharing! However, by default it can't add an eject option to the drive context menu. If I knew the code then it could be done.

In fact I found the code to write a reg file for adding a right click option to the drive menu. However, I have not yet found a comand line to eject the drive that actually works. The command line %windir%\System32\rundll32.exe shell32.dll,Control_RunDLL hotplug.dll does not work.

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\Drive\shell\Safely Remove]
"Icon"="hotplug.dll"

[HKEY_CLASSES_ROOT\Drive\shell\Safely Remove\command]
Write command here ???????????????

You are right that a clean Win10 installation is best. But in my case, I decided it would not be worth it for a relatively small issue. I guess I will just have to live with this issue.

Thanks for all your help and suggestions.

Kind regards
Chris

I wish there was a quick fix for this one. But drives can be non-ejectable and why that is, is already on the web. If that was it then some drives will offer eject and others would not. Fix? Probably a disk wipe of said media to force the drive to be clean and ready. The old HP USB FORMAT app used to fix these. It's been a few years since I've run into such drives so all I can offer is the thought.

I see we can eject with autohotkey, ejector apps and I think you wrote the system tray so it's just Windows File Manager that doesn't offer the eject. What we know is that the registry matters here but I can't find documentation to look through to see what that entry might be today. If you find such, share it and I'll look again. Microsoft appears to be removing OS level documention?

Be a part of the DaniWeb community

We're a friendly, industry-focused community of developers, IT pros, digital marketers, and technology enthusiasts meeting, learning, and sharing knowledge.