Recently everytime I open the IE it takes 10-20 secs to open, before the problem apear it opened in a sec, what can I do to fix it?

could be spyware. try Lavasoft's Ad-Aware.

Tried it just now, and it didn't work.

Do other Internet applications open right away? Try changing your homepage??

Do other Internet applications open right away? Try changing your homepage??

Yes othre internet apps open right away and i also tried to change my homepage and non work. something causing it because it worked pretty fast before, also I have P4 1.4 GHz 256 RAM.

Do you have a lot of add-in toolbars, like Alexia, Google, etc? Do you use popup blocking software? I find that a combination of all of these, especially popup blocking software dramaticly slowes down the IE launch.

Do you have a lot of add-in toolbars, like Alexia, Google, etc? Do you use popup blocking software? I find that a combination of all of these, especially popup blocking software dramaticly slowes down the IE launch.

No I don't have those stuff I have moved all my add ons and still it's slow.

Try, maybe deleting all "HISTORY" files.. Along with the TEMP and Temporary files. Also, set your start-up homepage to blank.. See if that works. *SHRUG*

Try, maybe deleting all "HISTORY" files.. Along with the TEMP and Temporary files. Also, set your start-up homepage to blank.. See if that works. *SHRUG*

ROFL..

Now seriously I already tried that didn't work.. it seems like its a real bugger.

re-install IE-6

Didn't work.

For my IE, i put my homepage as about:blank without that space after about. It loads much faster this way.

Problem solved!

I had problems with my HD till he died last week after i replaced it the IE is fast as it was.