Can anyone help me with this, zone alarm has totally blocked my internet connection, everytime i log on zone alarm brings up a message that says zone alarm has blocked internet access to your computer. I have checked the settings and the internet lock tab is set to off, i have even try setting access to medium level and it still blocks my connection. I have been using zone alarm for 5 months now and it worked fine, and i swear i did not change any setting at anytime. can anyone help.

Uninstall it, chances are you really don't need a personal firewall, its not going to be doing any help but consuming internet resources. ZoneAlarm is one of the not so good ones IMO....

I've seen alot of problems similar to yours with ZA and a few other free ones


I would argue that if you have a 24 x 7 connection, you do need a personal firewall, especially to prevent access to file sharing on the Windows computer. If you are dialing up, and then disconnecting after checking your mail or whatnot, then your risk is smaller due to your slow access speed, a random IP number, and that you are not online nearly as long.

Those of you who dialup all day though should have a firewall.

If ZoneAlarm will not allow you to do what you need to do, then the installation could be corrupted, or the program is not designed to let what you want to work execute properly. Perhaps a re-installation of the program will take care of the problem for you.



Personally I had been using ZoneAlarm for a few years. It worked well with my Norton Internet Security 2005.

So I am actually having 2 firewalls running on Win XP Srv PAck 2.

With no windows firewall on.

Try re-downloading the zonealarm program, and reinstalling it.

And make sure it does not conflict with other firewalls. Your previously permissions setup might conflict.

pls Give me more details on how Zonealarm hindered your net acccess.

I had a similar experience with Firefox and ZoneAlarm. I went into Program Control and selected programs. Scrolled to Firefox and hit the "Options" button at the very bottom right corner. Then I unchecked "Enable privacy for this program". See red arrow in photo