0

First off, just so you know my setup, I have a Cable modem, using a 4 port D-Link router to connect two PCs. Both systems are running Windows XP. I've used this router and modem for 2 years with no problems until now.

This problem is hard to explain, or has me completely baffled anyway. In a nutshell, I can browse the internet, send and recieve email, use instant messaging, etc. But I cannot play online games, which is my pastime. I've never had a problem connecting to and playing these games until this past week.

I first realized there was something wrong when attempting to download an update for Final Fantasy XI, which uses an online patching system to upate the software. The patcher would download the update but eventually get stuck on a certain file at 99%, and never continue. At first I thought this was simply a corrupt file, so I reinstalled the game, and tried to update again, only to have the same thing occur.

I also play a game called EverQuest, and I decided to see if there were any errors with it as well. It was fully patched unlike Final Fantasy, so I was able to log in to the game without needing to update files. I immediately noticed a problem - I was connected enough to remain in the game, but I could not perform any actions (this is hard to explain unless you've played the game). After a minute or two, I was disconnected from the game.

After virus scan, spybot and ad-ware turned up nothing, I decided to reformat my PC. However, even after reinstalling the apps on the fresh system the problem remained the same as it was before. This led me to believe it must be a connection related issue. When attempting to patch EverQuest, the patcher gives me "Internet Connection Error. Please check your connection and try again." While Final Fantasy XI is still able to begin the update but stops midway and is unable to finish.

My next thought was a router issue, since I've heard about them causing problems with online games. First, I tried simply running my ethernet cable directly into the cable modem, and bypassing the router (I dont know if this really does anything, but i tried it anyway), that didn't work. Next I reset my router settings to default and turned on DMZ to make sure the ports would be open for the games, no luck there either. Finally, I started checking these forums and downloaded WinsockFix which I thought might help, but things still remain the same.

Another curious thing I noticed is, if I attempt to update these games on the other PC on the network, a small yellow warning bubble pops up near the system tray saying something along the lines of "limited or no connectivity, you might not be able to access internet or some programs". However like I said, browsing the internet and other things seem to work fine.

Sorry for being so wordy and probably not explaining the problem well enough, but I hope someone here might have encountered a similar problem before.

Thank you for your time.

2
Contributors
1
Reply
2
Views
12 Years
Discussion Span
Last Post by alc6379
This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.