0

I am trying to make my home machine a webserver for a project I am working on. Here is my configuration

Windows XP Professional
Linksys Router

I set up my IIS server 5.1 to listen the default web browser on port 200. I have also tried 1000 8000 9000 2333 etc.... When I type the url http://192.168.1.20:200/index.asp from my computer or any computer inside my network everything works fine and page is served up. When I try to do it outside my network it does not work. PLEASE NOTE I AM USING MY IP that is assigned to me from Optimum Online when I try from the outside. I also use the WAN IP on the inside and it works as well. I have tried everything.

DOES CABLEVISION block all web traffic on any port from home servers?

Am I doing something incorrectly?

I even removed my linksys router from the equation and tried without it. Still nothing.

The error I receive is "Page cannot be displayed"


Is there a log somewhere that would tell me if the request is actually reaching IIS at all?

Any help would be appreciated.

Regards
Anthony

28
Contributors
50
Replies
55
Views
14 Years
Discussion Span
Last Post by vicepre
Featured Replies
  • 1
    Dani 1,665   14 Years Ago

    I know that OptOnline definitely blocks port 80. I think they might block all http: server requests on all ports, but not exactly sure. Read More

1

I know that OptOnline definitely blocks port 80. I think they might block all http: server requests on all ports, but not exactly sure.

Votes + Comments
need i say more? ;)
0

Oh, one more thing ... you have to set up port fowarding on your router. I know the Linksys ones (at least the one I have) support this feature.

Go to 192.168.1.1 to the router config panel, then to advanced, then to port fowarding. And make sure you have access from port 200 on the outside gets forwarded to 192.168.1.20 port 200 on the inside of your LAN.

0

Thanks for the info regarding the router. I already have port forwarding set already.

Does anyone know for sure if Cablevision is blocking all HTTP requests?

0

Nope, Cablevision is not blocking HTTP requests from home servers. Do you have a firewall set? Have you tried pinging yourself from the external IP? Also, have someone else ping you just to be sure.

0

I can ping myself and I can ping my IP without a problem from outside my network. I dont have a firewall set and I using a linksys router with WAN blocking disabled. I'm a techie and this thing is really starting to annoy me.

0

I am having the same exact problem. Somebody informed me earlier that Optimum Online does block the ports from home servers but he wasn't entirely sure. If anybody has Optimum online with a Linksys router and knows how to get the server up and running, then please post a reply to this thread.
Thank you very much in advance!

0

I have gotten my website up using my ip address:8000, but it did not work at :80. As soon as I changed it in iis, it went immediately. Also, I am using a linksys befsr41. The forwarding is necessary, as is, according to linksys, making your server static from the router.

Now a question... is there anyway to have people that go to my domain name automatically get to a different port than 80?

0

Now a question... is there anyway to have people that go to my domain name automatically get to a different port than 80?

Some people have told me it's possible but I've never tried on ports other than 80. Just watch out for Cablevision. I've already gotten two phone calls from them on how I can't run any servers. Yes, that's right, ANY. No Web, FTP, Mail, File Sharing. Ridiculous, eh?

0

OptOnline BLOCKS port 80 from outside your node. I run an FTP server which doesn't get hit very much, and sofar haven't had any problems with them. They also block 25 and 110, but if you have someone nmap your IP, it shows *everything* under the sun open and waiting. I think it's their filters, but I'm not sure.

Anyway, you can sign up for a free DynDNS service and run your httpd on any port you want, and have it redirected from the DynDNS service so it appears as though your server isn't being run from the back of your car so to speak.

I've also setup DNS to resolve one of my domains using their DNS servers to my local web/FTP servers, and sofar it doesn't work. *sigh*

1

They also block 25 and 110

Not true. OptOnline only blocks incoming TCP port 80.

What does that mean? You can not run a web server on the standard port.

Many protocols have default ports, HTTP is 80, FTP is 21, POP3 is 110, etc. In your web browser, when you type http://whatever.com, it connects to whatever.com's servers on port 80. The only way to modify this behavior is to append a :portno to the url, so http://whatever.com:240 would connect to whatever.com's servers on port 240.

A new type or redirector service which was refered to above, runs on an internet connection with an unblocked port 80 and puts your page in a frame in the browser (that fills the screen).

Here is an example: You run a webserver at 24.12.21.36 (made up IP addr) on port 81. You setup this special forwarding at a DNS provider (not all support this, because this is not a standard thing for DNS, its actually extra) to forward the url http://testsite.no-ip.com to http://24.12.21.36:81. When you go to http://testsite.no-ip.com, the dns provider (in this case, No-IP) sends you a page from their webserver with a frame taking up 100% of the page to the url of your site.

While this is useful, in many cases it has a lot of disadvantages. the actual domain does not resolve to your IP address - it resolves to your DNS providers. Also, all links contained on the site will not change the "Address" bar - it will always read your domain name only.

Anyone need any other help ;-)?

Votes + Comments
perfect post
0

Nope, Cablevision is not blocking HTTP requests from home servers. Do you have a firewall set? Have you tried pinging yourself from the external IP? Also, have someone else ping you just to be sure.

They certainly do filter. I called Tech support today and the engineer at Cablevision confirmed they filter 80, 8080, and others. So a web server is out of the question. I am looking into DNS port forwarding in hopes of getting around this. Then I could route http requests (on some other port) to my Linksys, then forward back to 80.

0

They do block. I have changed my ports and use a dns service to get around this.

Lets say you changed the port of your web server to 11111.

Set your linksys router to port forward 11111 to that machine. In the newer versions, you can use the UPnP to redirect 80 to 11111, but since 80 is blocked, this does nothing.

All you have to do now is create a webforward on your dns provider. Be sure that it is cloaked so the name stays the same.

1

So a web server is out of the question.

Cablevision is not blocking HTTP requests from home servers on ports except for 80. That I know for a fact. I've heard from other people that they've even gotten calls from running servers on non-default ports.

0

OK, got HTTP (Apache) working on port 5906 and mail (qmail) running normally on 25. I'm routing external requests for 5906 to internal port 80 (via my FreeBSD firewall/router), and it's been working fine for over 2 weeks now. I've also added SquirrelMail, which makes checking e-mail on the road a snap. I've had FTP running normally on port 21 for over 2 years now, and I'm hoping the additional bandwidth isn't going to draw any attention to OptOnline anytime soon...

0

On a similar note, does anyone know if optonline blocks hte bittorrent ports (i.e. 6881-6889, 6969)? I was going crazy trying to get BT working with my router. I tried all different combos of port forwarding, special apps, finally put my pc IP in the DMZ, not luck. Then I bypassed my router all together and it still appeared to me that I was not getting any BT traffic that I didn't initiate (e.g. no peers were connecting to me, but I was connecting to peers).

THis is driving me nuts.

Thanks.:sad:

0

Sorry, don't know anything about Bittorent ... but TheOgre, doesn't OptOnline block port 21 as well?

0

Sorry, don't know anything about Bittorent ... but TheOgre, doesn't OptOnline block port 21 as well?

Nope. My FTP server has been online for over 2 years without a problem, running on port 21.

I don't know too much about BT, as I haven't had the chance to play with it yet. As far as I know, OptOnline only blocks port 80.

0

cscgal, TheOgre,

Thanks for the replies. I'm now thinking that either I don't know how to set my router (SMC Barricade) up correctly or it's not working correctly ;o)
I tried the port forwarding, special apps, and combos of both and couldn't get it (BT) to work correctly. I then put my boc in the DMZ and still no luck. (I also noticed that when I check my IP address in in the router config I get 192.168.x.x) isn't this a non-routable address?) Anyway, I then disconnected my PC from my router and plugged directly into the modem, still no luck (which is why I thought the BT ports were being blocked). However, I unplugged my modem and tried again and it now works, so those ports are not being blocked which leads me to thinking I don;t know how to set up my router for port forwarding correctly (though it seems simple enough).

0

I had a chance to play a lil bit with BT and didn't have any problems, which leads me to believe that your router isn't configured properly. You shouldn't have to do any special changes to your router, since the connection originates from within your LAN, and a properly configured router will automagically allow replying packets back through (unless the prot:port is blocked specifically, like for the Blaster worm or some such.)

If you're wanting to check your outside IP, you could use this address. (and yes, anything 192.168. is non-routable. I forget the RFC, but yes, you're correct :)

Try resetting your router back to it's factory settings (or just remove all port forwarding settings) and try it again. I've never used that router, but I know for me to use BT, I had to make 0 configuration changes on mine.

Let me know how you make out.

0

Thanks for following up on this it is much appreciated. After resetting the router to the factory defaults, I still had the problem. It was driving me crazy, I mean I put my box in the DMZ (hard to screw that up, right?) and it still didn't work correctly (you're correct that BT will work fine w/o port forwarding or special apps, but setting up those features (not sure at this point whether 1 or both are needed) you can improve the through put by allowing people outside to initiate a connection).

Anyway, last night I'm sitting there with a dumb look on my face trying to figure out why it's not working, then it hit me. A few months ago, I became a beta tester for ViIP. The set up has the Telephone Adaptor in front of my router so I disconnected it and went from the modem directly to my router and presto! it worked. Unbeliveable. . . .

0

192.168 is the IP address for your computer on YOUR network only, so you would have to get a static IP, I am not sure on how to do this, just search google.

0

192.168 is the IP address for your computer on YOUR network only, so you would have to get a static IP, I am not sure on how to do this, just search google.

Actually, you don't need a static IP to run a webserver, but it does help. You can use a dynamic DNS service that will update your IP if it changes, so your domain will (almost) always resolve to your public IP.

FYI: 192.168. is a non-routable network address, not an IP address. 192.168.0.1 is an IP address :)

0

Actually, you don't need a static IP to run a webserver, but it does help. You can use a dynamic DNS service that will update your IP if it changes, so your domain will (almost) always resolve to your public IP.

FYI: 192.168. is a non-routable network address, not an IP address. 192.168.0.1 is an IP address :)

I think he's talking about getting a static internal IP, instead of being assigned one via DHCP. In this case, it is very preferable to be static ;-). Also 192.168. is his abbreviation for a 192.168.x.x IP, so don't pick on him :confused: .

0

I wasn't picking on him :) It was a very long day that ended about 2 hours ago. Just wanted to let him know, in case he wasn't sure...

(Now do you know why I got the nick TheOgre? :)

0

Could someone help me with the same problem as the original poster? I'm trying to reach my site (hosted on my home machine) from work. The firewall at work blocks all ports except 80. So I have to go out port 80 at work, but I know that OptOnline blocks 80. So I set up a WebHop with DynDns that redirects to a port on my home machine. I tried a variety of different ports figuring OptOnline blocks some of them, but nothing seems to work. Any help would be greatly appreciated.

0

Could someone help me with the same problem as the original poster? I'm trying to reach my site (hosted on my home machine) from work. The firewall at work blocks all ports except 80. So I have to go out port 80 at work, but I know that OptOnline blocks 80. So I set up a WebHop with DynDns that redirects to a port on my home machine. I tried a variety of different ports figuring OptOnline blocks some of them, but nothing seems to work. Any help would be greatly appreciated.

a little more info would be helpful, in particular, the internal (from "modem") network layout, and your protocol config; along w/anything else that you believe would be pertinent

0

Sorry for the lack of info. I'm not using a router. I just have the cable modem. I also have Zone Alarm installed which I turned off to do my testing. I'm running IIS 5.1 on a Windows 2000 machine. I have the web hop configured with DynDNS so that when I type in my URL (http://bradmcnutt.webhop.net) with them, it redirects to http://69.115.43.20:5906/Cabinet/ on my machine. This URL works fine when going to it on my machine, but like I said, when I try it from work, it can't find the page. I hope this is enough info. Let me know if you need anything else. Thanks.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.