0

3-4 days ago I registered nameservers and created A records for ns1.altprice.com & ns2.altprice.com, going to http://ns1.altprice.com will show my server's msg - meaning server works fine.

Problem is when I assign those nameservers to another domain, e.g.: altprices.com - the domain won't load or resolve to the server, and http://www.intodns.com/altprices.com says "ERROR: One or more of your nameservers did not respond".

nslookup ns1.altprice.com - is ok
nslookup altprices.com - times out ?

I spent a few days trying to figure this out, searched quite a lot online - but still nothing... the server is with Amazon cloud but, I guess, that should not change anything?

2
Contributors
7
Replies
10
Views
6 Years
Discussion Span
Last Post by rch1231
0

Your nameservers are not responding to requests:

nslookup altprices.com ns1.altprice.com
;; connection timed out; no servers could be reached

The name servers are set to:

[rod@lptp1 ~]$ nslookup ns1.altprice.com
Server: 192.168.15.1
Address: 192.168.15.1#53

Non-authoritative answer:
Name: ns1.altprice.com
Address: 204.236.219.103

but I cannot ping them...
rod@lptp1 ~]$ ping 204.236.219.103
PING 204.236.219.103 (204.236.219.103) 56(84) bytes of data.
^C
--- 204.236.219.103 ping statistics ---
11 packets transmitted, 0 received, 100% packet loss, time 10940ms

0

Hm, you are right, can't ping the IP, that's odd, because you can open http://204.236.219.103/ - and it seems to work fine. Is ping command goes on port 53 - same as DNS?

Any ideas what could it be? (a working IP that can't be pinged?)

0

Hello,

Ping is generic and does not hit a specific port just the IP. Are you running a firewall? Your right about http being open (port 80) and so is ssh on port 22

Are you sure you want to continue connecting (yes/no)? yse
Please type 'yes' or 'no': yes
Warning: Permanently added '204.236.219.103' (RSA) to the list of known hosts.
rod@204.236.219.103's password:

I bet you have iptables (firewall) running or SELinux. If so you need to open port 53 for the nameservers... And I usually shut SELinux down as it does more harm than good but your call.

0

Well, there is no DNS service running, so port 53 is actually not needed (but just in case both, tcp and udp 53 are open). It used to be the http deamon would just accept the request and return the page... but with Amazon it's somehow different.

Amazon have security groups, with I believe is SElinux, but I can't shut it down, only configure. What I did, is open everything in the firewall, afte opening icmp protocol - ping works fine, tcp and udp didn't have any effect on the name servers problem :(

So... The IP and ns1.altprice.com are now can be pinged. But domain still won't respond.

0

SO I am confused. If these are nameservers then why are you not running a DNS service on them (bind, tinydns, etc).

0

Um... Isn't registering name server and setting A record sufficient?
The domain is registered with goDaddy, "I told godaddy" that ns1.altprice.com is same as the IP 204.236.219.103. I guessed when someone try to open www.altprices.com -> he will check where the nameservers are pointing to and then go there directly.

My logic was, that my server is not supposed to give any DNS replies nor receive DNS quieries, because my IP is the final destination to which godaddy's DNS service is pointing...

I just started listening to port 53 and writing logs, but here were 0 request and also no errors... so there are no DNS requests coming my way.

I think I'm getting more and more confused :)

0

By pointing your domain nameservers to ns1.altprice.com and ns2.altprice.com you are telling godaddy (and the rest of the internet) that any requests to find out the IP for altprices.com will be handled by them. To verify this you can use whois and nslookup like this:

whois altprices.com
[Querying whois.verisign-grs.com]
[Redirected to whois.enom.com]
[Querying whois.enom.com]
[whois.enom.com]
=-=-=-=
Visit AboutUs.org for more information about altprices.com
<a href="http://www.aboutus.org/altprices.com">AboutUs: altprices.com</a>

Contact: espaiz@gmail.com
	
Domain name: altprices.com

Administrative Contact:
   
   Dmitry Brychosetsky (espaiz@gmail.com)
   +1.528332237
   Fax: 
   Jarusalem 23
   Natania,  42301
   IL

Technical Contact:
   
   Dmitry Brychosetsky (espaiz@gmail.com)
   +1.528332237
   Fax: 
   Jarusalem 23
   Natania,  42301
   IL

Registrant Contact:
   
   Dmitry Brychosetsky ()
   
   Fax: 
   Jarusalem 23
   Natania,  42301
   IL

Status: Locked

Name Servers:
   ns1.altprice.com
   ns2.altprice.com
   
Creation date: 22 Dec 2005 22:11:03
Expiration date: 22 Dec 2010 22:11:00

to query your local dns server:

[root@lptp1 ~]# nslookup alt.prices.com
Server:		192.168.1.254
Address:	192.168.1.254#53

Non-authoritative answer:
Name:	alt.prices.com
Address: 74.55.14.50

TO query a specific names server you simply add the nameserver to the nslookup. But ns1.altrice.com is not responding to my queries:

You might also try dig to get information on the nameservers:

dig altprices.com

; <<>> DiG 9.6.2-P2-RedHat-9.6.2-5.P2.fc12 <<>> altprices.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 33776
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;altprices.com.			IN	A

;; Query time: 342 msec
;; SERVER: 192.168.1.254#53(192.168.1.254)
;; WHEN: Mon Oct  4 12:48:56 2010
;; MSG SIZE  rcvd: 31

[root@lptp1 ~]# dig altprice.com

; <<>> DiG 9.6.2-P2-RedHat-9.6.2-5.P2.fc12 <<>> altprice.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 13035
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;altprice.com.			IN	A

;; ANSWER SECTION:
altprice.com.		3600	IN	A	204.236.219.103

;; Query time: 84 msec
;; SERVER: 192.168.1.254#53(192.168.1.254)
;; WHEN: Mon Oct  4 12:49:20 2010
;; MSG SIZE  rcvd: 46
This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.