0

Hey guys

I've seem to be stuck with a particular problem, which I just cant solve. Here is some background info.

We are small company with 8 users.

We have a shared network drive on the development server (Windows Server 2008 R2) we use to sync our development code/other files. This server is connected to domain SBS 2008, which manages our mail/domain and has 2 Hyper-V running.

2 Physical Servers / 4 laptops and 4 desktops (7 Hyper V machines)

All our machines are running Symantec Endpoint Protection

The problem I have is the following, all our users can sync (Beyond & Compare) files without any issues to the server, apart from 1.

When he used Beyond and Compare to sync files, it would start and just hang. And manually coping would work then. This problem started about 2 weeks ago.

But today even if he tries manually copy files to the server, it will start, then just hang after 3-4 seconds.

Now, this is the things I've tried to do.

I took away his folder permissions on the shared drive, and re-added him.
I've deleted his DNS records on SBS, recreated it and gave him a fixed IP address.
I connected him to the wireless router and disabled his local network adapter and visa versa.
Tested his network jack/cable with my own laptop (and it works fine on my machine) so its not the network itself.
Disabled his Firewall/Anti-Virus

And none of these helped.

Its quite frustrating to him, because now he has to put his code on a external drive, and bring it to me each time he has to sync his files.

Maybe I'm just missing something simple and somebody will be able to help me.

Any help would be appreciated. I'm just a programmer, not a Server Admin (even thou I maintain the servers lol, but I have a basic understanding on how it works.)

Thanks

Edited by Techyon: Added more information

3
Contributors
11
Replies
13
Views
5 Years
Discussion Span
Last Post by Techyon
0

Have the developer download wireshark or better yet run wireshark on the server. Start the packet capture before he attempts to copy the files and run it for ~15 seconds after the packet capture fails. Take the PCAP file and upload it here or send me a private message (see disclaimer below) and I can take a look at whats happening.

WARNING: Password hashes and other sensitive information could be contained in the PCAP so I do not advise internet distribution unless you have thorougly scrubbed the PCAP file. However scrubbing the file could erase error messages necessary to solve this issue.

If I had to guess I would think AV was the issue. Did you disable AV on the domain controllers, file server and developer workstation?

0

Thanks, I will do that.

I have AV disabled on the developer workstation/file server. As for the domain controllers, I'm unsure.

I will do the wire-shark suggestion and send you a PM, thanks a lot for helping out.

Much appreciated.

0

Ok, I've got an update.

I did some tests, it seems I can copy small files 1MB < Less without any problems every time and its quite fast, but if I try to send a big packet 1MB > it hangs.

I just remembered that I redid the Hyper-V's network adapters a few weeks back, when I added a second development machine. (DEV-2). I had to delete the Virtual Network and recreate it to enable virtual LAN identification on the new development machine adapter. Because without it, DEV-2 wouldn't connect to the internal network.

Edited by Techyon: Additonal Information

0

Has the problem been fixed or is it still misbehaving?

If you have multiple networks/subnets one thing that comes to mind is ICMP redirects. When the file copy starts it could be sending data along route-a then after a few seconds an ICMP redirect is received causing the route to change to a broken route, stalling the file copy. Just a hunch -- we'll know for sure with the wireshark logs.

0

No, the problem persists, because of the sensitive data you mentioned, they are still debating the wire-shark logs solution. The laptop in question is one of the Directors (Lead programmers).

He decided to reformat his pc today. So, if it worked, I'll update the thread, otherwise expect a pm from me.

Sorry and thanks for the help!

0

Seems like the formatting did the trick -.-

I'm still bewildered as to why this happened thou

0

As am I but its too late to find out :)

Please mark this thread as solved (since you solved your own question!) and good luck.

0

As am I but its too late to find out :)

Please mark this thread as solved (since you solved your own question!) and good luck.

Thanks for all the assistance

0

Well, seems like we will get a change to find out whats happening

problem persists =p busy installing wire-shark as I'm typing this.

0

Seems like it was faulty drivers on the server. When I reinstalled them, the problem went away.

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.