0

I have been reading though various articles but I cant figure out how to share files. I have a Linksys WRT54G with my desktop wired to it and a laptop using it wirelessly. Both computers use Win XP Pro. I just need a little help on extacly what I have to go through to be able to connect to each computer using the other. Thanks for any help.

4
Contributors
13
Replies
14
Views
11 Years
Discussion Span
Last Post by mp3aco
0

Unfortunately since you don't have a domain controller you'll have to enable the 'GUEST' account (quick and dirty fix). Also, check your network adapter properties to ensure File and Printer sharing is enabled, along with your Firewall settings (File and Printer settings ALLOWED).

0

Unfortunately since you don't have a domain controller you'll have to enable the 'GUEST' account ...

Or create an identical user account on both computers, which would be not quite as "dirty" a fix.

0

Or create an identical user account on both computers, which would be not quite as "dirty" a fix.

I already have two accounts with identical names. Both computers have file and printer sharing allowed. I already created a workgroup, but when I try to "view workgroups" I get an error messege saying "'workgroug' is not accesable. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permision.
The list of servers for this workgroup is not currently availible"
Could there be some setting I have to change on my router? I looked through all the settings but didnt see anything that seemed wrong but I didnt really know what I was looking for either.

0

I just tried activating the guest account and got the same error message on both computers. (I didnt have to restart my computers though, right?)

0

The router settings are probably OK; that error is usally a result of a misconfiguration on one or both of the workstations.

* Is the router connected to the Internet? If so, can both computers access the Net with any problems?

* Here are some things to check, and some troublehshooting steps to try. When going through the steps, please perform all of them, and give us the detailed results of each and every one in your next post:

1. When troubleshooting any network-related issue, the first thing you need to do is to completely disable any firewall software (including XP's built-in ICF/ICS features). Simply choosing the "Disable" option in the firewall program's settings/preferences rarely turns the firewall off entirely; you will need to deselect the preference setting that tells the firewall to automatically start when Windows boots, and then restart the computers. After reboot, verify that the firewall is indeed disabled.
Keep your firewalls dropped until you get things working.


2. Make sure the two computer's IPs and the router's IP are all in the same network range. If the router is configured as a DHCP server, it should supply the correct addressing info for you; you can check the computers' IP info by opening a DOS box and typing the following command at the prompt:

ipconfig /all


3. While still in the DOS box, verify basic connectivity by pinging the IP of each machine and the router. The syntax of the ping commands is:

From computer #1:
ping IP address of router
ping
IP addresss of computer #2

From computer #2:
ping IP address of router
ping
IP addresss of computer #1

You should get 4 positive replies from each ping command.


4. Make sure that the Computer Browser Service is running on at least one of the computers. To check/start the service:
* Click on the "Run..." option in your Start menu.
* Enter the following in the resulting "Open:" box, and hit OK: services.msc
* In the list of services, locate the service named "Computer Browser" and double-click on it.
* In the General tab of the Properties window that opens, click the Start button if the service is not already started.
* Once the service is started, choose Automatic in the "Startup Type" drop-down menu and then click OK.


5. Set up a shared folder on each machine. Once done, go back to the DOS box and try the following commands:

From computer #1:
net view IP addresss of computer #2

From computer #2:
net view IP addresss of computer #1

The "net view" command should list the available share(s) on the machine you target with command. If the command gives you an error, please post the exact text of that error.


One special problem that can occur:

If you've had your laptop connected to other networks, there's a chance that the DHCP server on one of those networks has made a modification to the laptop's Windows Registry which will cause browsing problems on a home network.

The Registry value in question is HKLM\SYSTEM\CurrentControlSet\Services\NetBT\Parameters\DHCPNodeType
For normal home networking, the Data Value should be set to "1" or "4".
Let us know if you need help with checking/modifying this value.

0

Okay.... I did everything you said and it all worked, I can now view the computers on the network and everything and I have no clue why its working now and wasnt before. Im going to try turning on my firewall and antivirus again and see if it still works. But so far thanks for the help, Ive been wanting to learn the diferent commands in DOS and how to use them and this has taught me a few new ones.

0

Ok mabey I spoke too soon. I can view my workgroup from my desktop but not my laptop...

Alright, when I turn Norton firewall on my laptop on I cant view the work group on my laptop but the opposite is not true on my desktop. I can have norton firewall enabled on my desktop and still view the workgroup. Im gona play around with it some more and try to figure it out but if anyone knows what to do that would be great.

0

Now I cant view the workgroup from my laptop at all. When I type net view "Ip for desktop" I get "System error 53 has occurred."

0

I restarted my computers, had all the firewalls turned off on them, and then tried to connect to the workgroup. I cant connect to the workgroup on either computer now. I can ping each computer from the other and ping the router from each computer. I can net view "IP of computer" each computer and view the sharded files but I can not net view. When I type net view I get "System error 6118 has occurred. The list of servers for this workgroup is not currently available".

0

*Groan*
The symptoms you're experiencing could be caused by anything from lingering firewall/ICS issues to DNS problems. Without being able to look at your machine, I can't honestly tell you where the best place to start would be.
Many of the different possible causes for the error(s) you're receiving are covered in the links below; please try the suggested fixes and repost here with the exact details and results of your troubleshooting:
(Note that some suggestions involve installing IPX/SPX; do not do this.)

http://support.microsoft.com/kb/298804
http://www.experts-exchange.com/Networking/Microsoft_Network/Q_20847982.html
http://www.experts-exchange.com/Networking/Q_20877736.html
http://forums.whirlpool.net.au/forum-replies-archive.cfm/441615.html
http://hidev.com/Technical/neterrors.asp

0

Ok I think I got it. I had to change a setting in Norton Firewall that was blocking windows file sharing. I restarted my computers and both can view the workgroup.

0

I have similar problem to APEX-jb. In the thread DMR gives a list of commands and it is at #5 referring to setting up shared folders on each machine and from a DOS prompt type
net view IP addresss of computer #2” This is where I get hung up. I get two error messages: on computer #1 – “Windows cannot find the network path. Verify that the network path is correct and the destination computer is not busy or turned off. If windows still cannot find the network path, contact your network administrator.”
on computer #2 – “The workstation service has not been started. More help is available by typing NET HELPMSG 2138.” “The service cannot be started, either because it is disabled or because it has no enabled devices associated with it.”

I preformed steps 1-4 with no problems. Have I missed something?

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.