0

My computer is running Windows XP SP2 and has a wireless connection to the internet. Attached, via a crossover cable, is my laptop running Mandriva 2007 (Linux - but then I guess you knew that). I know that there are some issues concerning file sharing with the new Mandriva, but I am also having problems with internet sharing.

The problem lies with XP:
When I go to switch on Internet Sharing I get an error message saying "The service database is locked". I have looked under services.msc and see nothing that should be enabled/disabled that isn't. So, XP isn't letting me share my internet...which is highly irritating.

I have tried to Google the problem, but no-one seems to have come across this problem before. Hopefully someone will know how to solve it though.

Any help would be gratefully received.

3
Contributors
4
Replies
5
Views
10 Years
Discussion Span
Last Post by blud
0

Have you tried choosing Start->Run and typing in winmsd ? Go to the Service tab, and look for something that says "Start pending". If there is, then you've found the problem. If it's an non-essential service, you can disable it using the Registry Editor.

0

I found the solution to the problem, which was a program that was confusing the internet (one of my earlier attempts at solving the problem). However, now I am in the situation whereby my laptop can only seem to use Google - no other web page can be retrieved.

I was wondering if I was better off switching the ICS host to the linux laptop, and having the main PC as the client. It defeats the point of a portable laptop, but if it solves the problem....!

0

However, now I am in the situation whereby my laptop can only seem to use Google - no other web page can be retrieved.

Can you ping hosts? Open up the MS-DOS prompt, and enter something like:

ping hotmail.com

If it returns with 64.4.33.7, it can at least lookup the IP addresses. Also, with the IP address it returns, why don't you try entering that into the browser's address bar? If that works, it might yield a clue to why the connection is not working.

0

His laptop is linux, so while the ping command will work the same, I would also making sure that you have valid Nameservers listed in your /etc/resolv.conf file.

You can try to use:
Nameserver 4.2.2.1
Nameserver 4.2.2.4

(These are Generic GTE Nameservers)

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.