0

Hi, all - my first post here. I chose this forum to replace the one I've always belonged to and been a part after I disagreed with some of their policies (not helping anybody with P2P file sharing software installed, to be specific). I've landed here many times after googling for various PC issues I've had. The site has always been most helpful and the knowledge of the members transcends most other websites. I hope that I can be a valuable contributor myself.

Now, to the issue at hand. Despite my best efforts, I somehow caught a Trojan. While it was eradicated almost immediately, it left some significant damage behind, specifically, LSP and Winsock (I don't know much about these particular items, but everything I read led me to believe the issue was somewhere along these lines.) At any rate, after trying to get everything back-to-normal for a couple of weeks, I finally just gave up and decided to do a repair-install. Upon exiting from the repair install, of course I needed to get updates from MS. Unfortunately, my PC was in some sort of Update Hell, as the updates would download, but would fail upon installation, saying that a prior update was still in progress and that a reboot was required. I would reboot and the Update facility would once again download the same updates, fail the installation, tell me to reboot, and so it goes. NOTHING I tried to do would solve this issue, and I tried every solution I could find on the net, including re-registering, uninstalling and reinstalling the update facility, changes to the registry, etc. Finally, I'm not sure what happened, but after hours of trying and me finally leaving my PC in disgust, when I returned the next morning, the updates had magically downloaded! Well, I suspect when the automatic updates system was allowed to be fully in charge, somehow something got reset and that allowed the updates to occur.

But here is the problem. All references, and I mean ALL references have been totally deleted from anywhere on the PC. Network Connections is entirely blank (and this issue shouldn't be confused with a similar network issue, documented by MS, that describes many of the same conditions, but with full network connectivity. I have none). So, something in the updates has caused my PC to lose network connectivity. Or it's possible that one of the few registry tweaks I did in trying to make things right again with the update functions did it and I didn't notice I had lost network connectivity (I don't believe that is the case, though) It's as if the network or any of the components never have existed. For example, when I type "arp -a" what comes back is a one-line reference to "Microsoft ARP" or something along those lines (I'm on a different PC as I'm in the process of installing another XP to have a dual boot configuration until I can figure out what is going on). The network diagnostic utility says that no network is installed, and if I try to load the drivers for the NIC, the system says "you don't have a network installed or a card, so you can't install these drivers" - something like that. I've tried SFC, and everything else that I can possibly think of. Any ideas of things to try? At this point, it sure can't hurt to try anything because I'm dangerously close to having to do a full wipe/format/reinstall, which is pretty terrible because I'm not well backed-up, particular with my music. I just would really prefer not to do that at all. I would be devastated if I were to lose over 1500 songs! Thanks in advance -

2
Contributors
1
Reply
2
Views
10 Years
Discussion Span
Last Post by jimlaver
0

Just taking a wild shot.. have you checked if the network connections service is started?

Run services.msc and check on the "Network Services" and on the "Network Location Awareness" lines to see if their status es "Started". They should be on manual startup but for some reason they could be stopped.

Good luck.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.