0

This should be a really simple thing, but for some reason I have had no luck getting anything to work. I have CLISP and GCL, and on neither can I specify where a file is using the load function. I've tried setting the pathname, but it removes the backslashes, so its not looking in any directory, let alone the right one. Basically, I want to do this:

(load "c:\users\documents\john\schoolwork\cs\3600\project3.lisp")

But it says it can't find the file c:usersdocumentsjohnschoolworkcs3600project3.lisp

similarly when I try and set the pathname, it removes the backslashes. Anyone know what I'm donig wrong? I figure it's something really simple, but I just can't figure it out, and none of the documentation actually has examples with a windows path involved.

Thanks.

4
Contributors
4
Replies
5
Views
10 Years
Discussion Span
Last Post by rockout690
0

If the backslash is used to start escape sequences in Lisp, the compiler will remove it and replace it with whatever \u (for example) represents (which may be nothing). Try escaping each backslash with a backslash i.e.

(load "c:\\users\\documents\\john\\schoolwork\\cs\\3600\\project3.lisp")

If this fixes the problem it is likely this rule wil apply in all quoted strings within the language.

Steven.

0

This should be a really simple thing, but for some reason I have had no luck getting anything to work. I have CLISP and GCL, and on neither can I specify where a file is using the load function. I've tried setting the pathname, but it removes the backslashes, so its not looking in any directory, let alone the right one. Basically, I want to do this:

(load "c:\users\documents\john\schoolwork\cs\3600\project3.lisp")

But it says it can't find the file c:usersdocumentsjohnschoolworkcs3600project3.lisp

similarly when I try and set the pathname, it removes the backslashes. Anyone know what I'm donig wrong? I figure it's something really simple, but I just can't figure it out, and none of the documentation actually has examples with a windows path involved.

Thanks.

----------------------
Get rid of the double quotes and make them single quotes, lisp is reading your backslashes as attempted escape characters and stringing the whole thing together.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.