Hi

Its been about a year since I've been on this site, Back when I use to use XP for my operating system and Dev-C++ for my compiler. But Now I have WIndows 8 and I tried downloading Dev-C++ but I kept getting this message. "g++.exe has stopped working." So I downloaded Microsoft Visual C++ 2010 and I don't know how to compile. When I build I get this message

1>------ Build started: Project: HelloWorld, Configuration: Debug Win32 ------
1>LINK : error LNK2001: unresolved external symbol _mainCRTStartup
1>c:~\visual studio 2010\Projects\HelloWorld\Debug\HelloWorld.exe : fatal error LNK1120: 1 unresolved externals
========== Build: 0 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========

I would appreciate any help.

Thanks

You probably got your settings wrong to start with. When creating a new project, select Win32 in the left pane of the New Project window. Then select Win32 Console Application in the middle pane. Give it a name and then click on OK.

In the next window (Application Wizard), click on Application settings and then check the box labeled Empty Project and then click Finish

Try that.

Edited 4 Years Ago by MandrewP: Correct spelling .... spell check doesn't work anymore in text box1 : (

I did exactly that. Still got the same error message. I used visual studio before and I have no idea whats wrong

OK, click on the Project menu at the top and then on properties at the bottom (maybe project properties?)and then in the property pages window click on Linker and then System. Then in the pane on the right, make sure SubSystem is set to Windows (/SUBSYSTEM:WINDOWS)

Edited 4 Years Ago by MandrewP: typo....

It was set to Console (/SUBSYSTEM:CONSOLE) so I changed it to Windows (/SUBSYSTEM:WINDOWS) but it still didn't work

By the way I thank you for your continued help.

Any other ideas.

I got the WIndows 8 consumer review version

By the way I'm running a 64 bit operating system. I don't know if that helps you at all

Well then, I think I will just join you as one who ain't got a clue. It probably has something to do with that Windows 8 thingy. Sorry.....

You have to uninstall Mingw first.. and DevC++.. I'm on Windows 8 and it works VS2010 and codeblocks works fine..

Consumer Preview here.

hey boss I was try and error, the way to fix it is just klik tools then compiler and options/tabs to program
then change c++ with MIngw c++ and g++ with c++ and you can try it now, thank's

U really shouldnt try DevC++ with windows 8, firstly coz its probably a beta version of windows 8 ur running and secondly.. DevC++ = Steam Engine, Windows 8 = Ferrari... U fit a steam engine into a ferrari.. its surely not going to work... Try running DevC++ in the windows xp compatibility mode.. u can do that by right clicking the icon and then selecting 'Run in earlier versions of windows' !!

This article has been dead for over six months. Start a new discussion instead.