Hello,

i have created a vb project and have publish it. There is no problem in running the vb.exe in my laptop but when, i try installing the vb.exe in my friends laptop the are error, error signiture (event type : clr20r3). I tried installing visual studio in my friends laptop and the vb.exe run smoothly. I need the vb.exe to run on its own, with or without the visual studio. Any suggestion?. Thank you in advance.

I need the vb.exe to run on its own, with or without the visual studio. Any suggestion?

you need to use package and deployment wizard. It will create installer of it so that you can run it wihout having installed Visual Studio.

Edited 2 Years Ago by Learner010

you need to use package and deployment wizard. It will create installer of it so that you can run it wihout having installed Visual Studio.

Thank you for your suggestion..I have already tried that too..doing the installer..but the result is the same..i even tried using "inno setup" to compile everything in one..but the result is the same..

there is something that i read about the dll file. to compile it together or something like that..but i dont have a dll file when i publish all the files. Do i need the dll file?..anyone know about it..

there are other forum that i read about. he deleted the visual basic powerpack or somewhat on the solution tab under installer. i have the powerpackthing.dll..i tried to delete it but it cannot be deleted. it can only be hidden.

My laptop is 32bit OS and my friends laptop is 64bit OS..with the same window7..does it make any different??or is it, maybe one of cause??..

i really dont know what else to do. please help me and give me as many opinion and suggestion or solution you know..

Thank you so much..

You could just share the .exe of the app located under C:\Users_Your_NameUser_\Documents\Visual Studio 2013\Projects_Your_Project__Your_Project_\bin\Debug

But if you still want it to be installed try installing Microsoft C++ Redistributable.. I think that includes all the necessary files for it to work...

Edited 2 Years Ago by Vaggelis

oh, this happens with me too (but not remember exact error, it was something like this only)
This happens when I publish my application with click once .
(It may because of framework or something else.)
I tried: Advance Installer and then it works fine, from that time i am using advance installer.

As you told, you try Inno setup. (i haven't try it, so no idea on it)
So I will simply advice to try the exe file that located under Documents/.../project/.../bin/debug/appname.exe
on your friend PC and analyze the error, if so then there is something bad with application, (You should try to target .Net Framework 2.0 as it is mainly available on all windows)

If not so then reply me, I will try to search that error in deep.
Thank you

I change the project platform..the one that i am using is 32bit whilst the other computer was 64bit..so silly of me..thank you, everyone..

This question has already been answered. Start a new discussion instead.