Install iis 7 on your vista os.Open up the iis manager from administrative tools. Right click default web site and choose add new application. Give your application(your site) a name(alias) and point to your physical application folder. open up your web project in visual studio. Right click the web project and choose property pages. click to start options and choose the "start url" of the radio buttons in the start action section and type http://localhost/yourAlias/yourHomePage.aspx.
Then in the server section below, choose use custom server and type http://localhost/yourAlias as the base url. To enable debugging with visual studio, open up the iis again and right click to your web application, select Advanced Settings. In the behaviour section there is Application Pool property choose the "Classic .Net AppPool" from the options. You are done! You can now use the real webserver instead of the virtual one. Firefox runs incredibly fast when iis 7 is used, whereas it sucks in terms of speed when web developer server is used.

Thanks a lot Serkan ┼×endur, I understand everything you explained. But you have told about installing iis 7 in Vista, but I use Windows XP Service Pack 2 & the IIS ver. 5.1. Is it all the same in WinXP SP2 and IIS ver.5.1 ?

Thanks...
Abhijit

Hi
You wrote .."To enable debugging with visual studio, open up the iis again and right click to your web application, select Advanced Settings. In the behaviour section there is Application Pool property choose the "Classic .Net AppPool" from the options. "
But..in my option window/Application Pool property there is only "DefaultAppPool" to choose.
Why?
Could you answer, its quite urgent and havent got a clou about vista and iis7 :P
thx

Hi
Yes ive got IIS 7 installed
My solution of the problem was that ive added "Classic .Net AppPool" manualy to the AppPools
Thx for your reply

serkansendur I have developed an asp.net 2.0 application running in the local file system and I tried to do what you wrote to your first post.
Now I am getting an error :

HTTP Error 500.19 - Internal Server Error
The requested page cannot be accessed because the related configuration data for the page is invalid.

Detailed Error Information :

Module IIS Web Core
Notification BeginRequest
Handler Not yet determined
Error Code 0x80070005
Config Error Cannot read configuration file due to insufficient permissions
Config File \\?\C:\Users\Admin\Documents\Visual Studio 2008\WebSites\Aspis2\web.config
Requested URL http://localhost:80/Aspis/AjaxDefault.aspx
Physical Path C:\Users\Admin\Documents\Visual Studio 2008\WebSites\Aspis2\AjaxDefault.aspx
Logon Method Not yet determined
Logon User Not yet determined

Any idea how to fix that?
Thank you!

I also can't see my application in inetpub directory.
Shouldn't it be copied there?
Thanks again.

This question has already been answered. Start a new discussion instead.