Start New Discussion within our UI / UX Design Community

Hi everyone, i'm having a strange problem with firefox not displaying my frames correctly.
Basically i have 4 frames= _header, _leftMenu, rightMenu, _blockText
now in the left menu i have a link like this for example

<a href="general/welcome.html" target="_blockText">Welcome Home</a>

as you can see target=bla bla should give me the linked page in that frame as it does on safari but NOOOOOOOO firefox is special and it opens it in a new window

the website is up to test
http://web.me.com/smiro/Tricounty%20Intergroup/index.html
only the links on the "general" tab are active to test

i apreciate your help very much, i've been trying to rap my head around this for days....

much love,
-smiro

sorry but could you be more specific?

you mean like this?

<li><a href="welcome.html" target="_blockText" name="_blockText">Welcome Home</a></li>

No like this

<frame src="welcome.html" frameborder="no" scrolling="auto" noresize="noresize" marginwidth="0" marginheight="0" Name="_blockText" id="_blockText" />

This is because target= is deprecated.

What is new replacement of target then? Sorry I'm just plain lazy to look it up in documentation...

As far as I can find out, they didn't come up with a replacement, just as they didn't come up with a nice replacement for center.

Another possibility is that the Firefox browser you have is set to always open new pages in new windows.

Another possibility is that the Firefox browser you have is set to always open new pages in new windows.

No, on some forums like daniweb all links open in new window/tab, but there are many other forums where the link open in same window and in doing so overwrite display of original source.

This question has already been answered. Start a new discussion instead.