0

I have (or rather had) a 70 in 1 external card reader. I was working fine of late, but today I plugged it into my laptop (with SD card in it) and all the Removable Drive (*) popped up but there was nothing "inserted" in the drives..... Grrrrrrr.

I though it might be so because my laptop aint the newest laptop, so I tried it with my desktop (not latest model) and again the removable disks (*) popped up with nothing "installed" but this time it caused my USB mouse to fail. I thought It just might have been a glitch so I tried it again and still no luck..... AAAAARRRRRGHHHHHH.

Needless to say I lost my temper and SMASHED the card reader into lots of little pieces.

What could cause this to happen?????? Was the reader just buggered or are my computers just too dammed old?? My laptop is a HP Compaq nx9010 (about 6-8 Y/O) and my desktop is an old HP Compaq d510 SFF (about 6-8 Y/O)

Can anyone help as I am having a NOOB stage right now and my diagnosing skills are up the creek.

Thanks,

Shaun.

2
Contributors
1
Reply
2
Views
8 Years
Discussion Span
Last Post by kaninelupus
0

To start with, what OS are we talking about? You need to be sure the card reader is supported by your OS, and that drivers are available (and on older system, pre-installed).

Also, are your machines fitted with USB2 ports, as if not card reader needs to be USB1 compatible

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.