0

Hi anyone help please, we have a Dell Inspiron 1525, was working fine then power started to flicker, it would go off then after a short time come back on again, this went on for a few weeks, then went off all togeather, not a scrap of power, green led was lit on AC adaptor but still i assumed that was the problem so bought a new one.

Connected new adaptor, not a scrap of power, don't know anything about removing bits etc.

Any suggestions please.

2
Contributors
2
Replies
3
Views
7 Years
Discussion Span
Last Post by WillsAsp
0

What happens if you remove the battery, plug in the A/C adapter, and turn on the system? If it still doesn't work, the motherboard is fubar. If it works, then the battery is kaput.

0

What happens if you remove the battery, plug in the A/C adapter, and turn on the system? If it still doesn't work, the motherboard is fubar. If it works, then the battery is kaput.

Cheers, tried that and still dead, managed to speak to Dell, their best advice was to remove battery and adaptor and press power button for 3 minutes, of course zilch happened, I have passed it over to a shop for assessment, see what they come up with, though they believe it to be the motherboard.

If the the laptop is kaput then I will kick off the biggest noise Dell have ever heard, I hate being ripped off £500 is a lot of hard earned ours at the office and I will not give it away to pratts like Dell.

Cheers again, will update this thread with outcome.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.