0

My external hard drive has been acting very strangely for the past few days, and I can't figure out what the problem is. The drive disappears intermittently from my system, then reappears as an "unformatted" drive, which is inaccessible via My Computer and recovery tools. If I unplug the drive's cable then plug it back in, Windows finds the drive and it becomes accessible again (well, most of the time). Occasionally when this problem occurs, an icon appears in the system tray. It's a yellow triangle with a black exclamation mark on it. If I click it with either mouse button, it disappears and the drive goes through its little "unformatted state" routine, so I can't figure out what the icon signifies. I've also tried hovering my mouse over the icon to see if any info would pop up, but it didn't.

I've had the drive since July 2007, and I've never had any problems until now. I upgraded my system in November of 2007, and again the drive worked fine until now. I'm stumped.

I'm using Windows XP Pro SP2, with all of the latest updates. I've run several scans with disc error checkers, including Windows' own, and they showed nothing. I've tried running a surface scan but the drive won't remain "seen" by Windows for long enough for the scan to even get half way (the drive is 500GB). I even tried uninstalling the USB entries in the Device Manager then rebooting, letting Windows find the device(s) and then reinstalling, to no avail.

The drive itself is a Western Digital Elements 500GB USB 2.0 External Hard Drive [WD5000AAKS]. I tried using the diagnostic tools from Western Digital's own website, but the same problem occurs, i.e. the drive changes state before the "deeper" scans can complete; the quick scans show no problems. I used a partition recovery tool to scan the drive and see if there were any problems in that department, but there were none (as far as I could tell).

I tried using a different USB cable, and plugging the drive into the front USB panel as opposed to the usual back one, but it made no difference.

My PSU is pretty beefy, so I'm positive that it's not a case of there not being enough juice to run the USB devices. Besides, the problem only started a few days ago, and I've been running the drive since July of last year without any issues (my old system had much less power than my upgraded one).

The information on my drive is accessible, so I could probably back it all up piece by piece, but in the meantime - any ideas? haha

Thanks for reading!

3
Contributors
23
Replies
25
Views
9 Years
Discussion Span
Last Post by mechbas
Featured Replies
  • Failing partion. Doesn't look good, maybe time to contact mfg. The curious part is that the HD works fine, or so you said, under another OS. If the partion had took your files would already be gone. If you've got another drive to do a copy, now's the time. What … Read More

0

The prob. with external devices of any type is that the connections cables tend to lose their connection, even if you are positive that the cable is is place it may not be, i.e. lack of continuity. Maybe a good idea to replace all of them.
If the above gives you no joy then contact WD's tech support. Specifically refer to this "but the same problem occurs, i.e. the drive changes state before the "deeper" scans can complete". They're going to want specifics such as mod# & ser# etc. so be prepared before you contact their site, saves time.

0

having the same issue - it disappears in XP, bluescrrens in Vista, but works perfectly in Ubuntu.

I managed to get the drive to run longer before it locks out by updating the system BIOS.

0

having the same issue - it disappears in XP, bluescrrens in Vista, but works perfectly in Ubuntu.

I managed to get the drive to run longer before it locks out by updating the system BIOS.

This gives me hope for my little HD; if it works in Ubuntu then surely it's a Windows issue. I wonder has something become corrupted in our systems...I got a Trojan recently (successfully eradicated with BitDefender) but I'm not sure if this was before or after the issues began, and I'm not sure if a Trojan could cause this sort of problem. I had one last year that disabled all of my security applications (BitDefender, Spybot, etc) so anything's possible I suppose.

If it is an issue with Windows would a repair install fix whatever's wrong? Or would it have to be a full reinstall? Or should I even bother? :P

If this isn't an option I'll contact WD and see what they say.

Cheers to both of you.

0

well, my XP is at SP1 level, I can't update it because of the software I am using on it.

my advice - move to Linux :)

0

Haha you have no idea how tempted I am to do that, but unfortunately this is a family PC and I can't be bothered teaching my folks how to use a new operating system when they can barely use Windows!

I may try a repair install later and see if it helps, and I'll report back with the results. If it doesn't work I'll contact WD and let them dictate the next steps.

P.S. I've heard that external drives can be removed from their casing and uses as a normal internal drive. Is this true, and if so, is it worth doing in terms of the overall stability of the device? It kinda defeats the purpose of having an external drive though, so I doubt I'd do it unless I knew for sure it'll solve the problems I've been having with it.

Thanks muchly!

0

well, if I had a proper PC I'd put the drive inside it, it's a normal sats disk in there, but since I have a laptop - no luck.
and Irish prices for computer parts are so high, I'll probably stick to my laptop and get my company to buy me a PC :)

0

>>>a Windows issue: if a vir. was involved a system repair may or may not work as unknown damage to other files may/may not exist and could become time consuming. If the HD is basically sound and it seems it is it's always worth the effort. With that kind of potential damage I wouldn't waste my time with a repair job, get my data files off, fdisk, format, etc.

>>>external drives can be removed : what you heard is true in most cases, it would have to be an extremely rare circumstace not to be. applies to CDs, DVDs, & HDs. If you do I'm sure you're aware that install protocals have to be observed, jumper settings, etc.

0

I'm not sure what the problem was exactly, but a reinstall of Windows solved it. I tried a repair install first, and like you predicted mechbas it didn't suffice (and in fact seemed to cripple my system!)

I decided to reinstall Windows after I tried plugging the drive into my brother's system. I was able to run full surface scans without any problem (and without any errors) which convinced me once and for all that the drive was not the issue, thankfully.

This probably isn't much help to other people who are having the same trouble, because reinstalling Windows doesn't really reveal anything about the problem, other than to confirm that the drive isn't at fault. But maybe some tech-savvy folks can dissect the issue a little better! The one thing that struck me as a possibility was the Trojan I mentioned, but unless DimaYasny has suffered an attack of that kind too I'm not sure if we can rule it out. Did you have any nasties on your system prior to your HD issues, DimaYasny?

Thanks for your input guys (oo err!), and good luck to you DimaYasny. Hopefully a reinstall will help you too :P Although a quick fix would be nice to save the hassle of reinstalling all of your apps and such.

Thanks muchly!

0

>>>reinstalling Windows doesn't really reveal anything about the problem

Repair installs usually DON'T work because the install puts on the original system files, drivers, etc. that DO NOT work with newer updated files that you get with the OS's updates. Interfile connections are either not there or are not suited to the newer files' needs and vice versa. The end result (in memory, (RAM)) resembles a traffic jam and/or a multi-car pile up. Replacing unsuitable files was hard enough under W3.xx. I expect you can imagine the task of doing the same thing with today's OSs.

0

False alarm - the problem came back :(

God dammit.

To what end?
Did you, by chance, check the OS's ability to mount that size disk?

(U posted about the same time I did.)

0

The problem is the same as before, in that the drive disappears then reappears as an "unformatted" drive. I can't even scan it with chkdsk when it's in this state.

The drive is 500GB, and I haven't had any trouble with it before. However, I don't think the drive has ever been as full as it is now. I'm currently using 310GB of space. Do you think this could be the issue? I mean, it shows as 500GB no problem, but when you start to accumulate actual data of that size the strange behaviour starts? If this is the case, does Windows XP Pro SP2 have the ability to support these kinds of sizes, maybe with a patch or the like? It didn't even occur to me that this may be a problem. After a cursory search on the net, I see that the motherboard and/or BIOS is a consideration, but I have an ASUS Striker Extreme; one of the latest motherboards.

If this is the problem (that the data, rather than vacant space, is the causing this), I suppose I could partition it once or twice. But I'd rather not attempt that until I'm sure that it will solve the problem.

Thanks mate.

0

A quick update. I upgraded my BIOS to the latest version, hoping that maybe this would correct the issue, but it did not.

I'm stumped!

0

>>>does Windows XP Pro SP2 have the ability to support these kinds of sizes
Actually I don't recall myself if it does or not, but it COULD very well be a valid issue. Would have to extensively us my search eng. for that much detail.
>>>one of the latest motherboards
I'm satisfied that the hardware can support that size drive and much larger, however, THAT doesn't mean that the OS will. Updated drivers? they probably don't exist. At the time the XP was first realeased that size drive probably existed only on some mfg.s drawing board. MS usually doesn't change something like that post release, ever.
You might try a partion of at least 75/25%, anything less would be pointless.

If you try to move this drive with the OS intact you're going to have continuous probs. The drivers, etc. are set up for a specific machine, unless they're IDENTICAL, and I do mean that, it ISN'T going to work. If this is only for file storage you can change it from one system to another w/o much prob.

0

I decided to check the Event Viewer to see if anything shows up, and I get hundreds of errors relating to my USB drive (I'm assuming it's this drive - in Disk Management the drive is "Disk 1", and the errors relate to \Device\Harddisk1\D, however the USB drive is E, not D. Bloody confusing!). Here is the most prominent error message:

Type: Warning
Source: disk
Event: 51
Error Message: An error was detected on device \Device\Harddisk1\D during a paging operation.
EventID.Net Entry

I also get these errors, but nowhere near as often:

Type: Warning
Source: ntfs
Event: 50
Error Message: {Delayed Write Failed} Windows was unable to save all the data for the file . The data has been lost. This error may be caused by a failure of your computer hardware or network connection. Please try to save this file elsewhere.
EventID.Net Entry

Type: Warning
Source: ftdisk
Event: 57
Error Message: The system failed to flush data to the transaction log. Corruption may occur.
EventID.Net Entry

Type: Error
Source: ntfs
Event: 55
Error Message: The file system structure on the disk is corrupt and unusable. Please run the chkdsk utility on the volume.
EventID.Net Entry

I also noticed that errors were corrected during a boot-time chkdsk, and the log shows the following:

Checking file system on E:
The type of the file system is NTFS.
Volume label is Storage & Downloads.

One of your disks needs to be checked for consistency. You
may cancel the disk check, but it is strongly recommended
that you continue.
Windows will now check the disk.                         
Index entry Firefox 2.0.0.11.rar of index $I30 in file 0xef points to unused file 0x1f6a.
Deleting index entry Firefox 2.0.0.11.rar in index $I30 of file 239.
Index entry FIREFO~1.RAR of index $I30 in file 0xef points to unused file 0x1f6a.
Deleting index entry FIREFO~1.RAR in index $I30 of file 239.
Cleaning up 3 unused index entries from index $SII of file 0x9.
Cleaning up 3 unused index entries from index $SDH of file 0x9.
Cleaning up 3 unused security descriptors.
CHKDSK discovered free space marked as allocated in the
master file table (MFT) bitmap.
CHKDSK discovered free space marked as allocated in the volume bitmap.
Windows has made corrections to the file system.

 488375968 KB total disk space.
 324247004 KB in 16267 files.
      8032 KB in 373 indexes.
         0 KB in bad sectors.
    112024 KB in use by the system.
     65536 KB occupied by the log file.
 164008908 KB available on disk.

      4096 bytes in each allocation unit.
 122093992 total allocation units on disk.
  41002227 allocation units available on disk.

Internal Info:
a0 79 00 00 0b 41 00 00 a8 7e 00 00 00 00 00 00  .y...A...~......
e4 04 00 00 00 00 00 00 3e 00 00 00 00 00 00 00  ........>.......
b8 5f e6 01 00 00 00 00 98 84 1d 07 00 00 00 00  ._..............
76 0a 73 02 00 00 00 00 00 00 00 00 00 00 00 00  v.s.............
00 00 00 00 00 00 00 00 18 0a d3 14 00 00 00 00  ................
60 02 0e 8f 00 00 00 00 e0 3d 07 00 8b 3f 00 00  `........=...?..
00 00 00 00 00 70 77 4e 4d 00 00 00 75 01 00 00  .....pwNM...u...


For more information, see Help and Support Center at [url]http://go.microsoft.com/fwlink/events.asp[/url]. 

Hopefully this will shed some light on the subject. Not for me, obviously, because I haven't a clue.

Cheers :)

Edited by mike_2000_17: Fixed formatting

0

>>>in Disk Management the drive is "Disk 1"
in older ver. of this OS HDs were given the first drive (folder) designations C, D, E, etc. and optical (CD) drives were given the last ones as they were installed, i.e. Master first and slave(if any) second. Currently tho, in WinExpl, the OS puts them in whatever order that you installed them after the initial OS setup.
If you happen to be online while in EventViewer you can click on the event Number and get some interpretation as to what it means, maybe you can make some sense of it, maybe not. I would guess if you're confused now what you get from MS isn't going to help much, but it's worth a try I would think.
CHKDSK usually runs AFTER some manner of OS hang causing you to either push the reset button or the power switch. (if the one in front of the box doesn't work too well the one on the PSU in back most certainly will)
I still haven't checked so I don't really know what, if any drive limitation the OS has but I'm still thinking that 2 partitions is worth a try.
CHKDSK runs under basic DOS mode, the OS generally runs under enhanced mode which may still be what is giving you the "runs" cuz it may not want to mount the entire drive causing an unrecoverable err., reboot, etc.
What CHKDSK said in it's summary is that the drive itself is basically sound. The rest is left to the OS's interpretation.

0

I tried partitioning the hard drive, but it failed at around 30 seconds into it. The drive wouldn't show up after that, so I went to the Disk Management options and had to reassign a drive letter.

Very curious. I think if I want to partition it I'll have to delete half of the data from it, which is something I don't really wanna do haha.

1

Failing partion. Doesn't look good, maybe time to contact mfg. The curious part is that the HD works fine, or so you said, under another OS.
If the partion had took your files would already be gone. If you've got another drive to do a copy, now's the time.
What did you use f/partition attempt?

0

You're not going to believe this...I think I nailed the problem, and it's so stupid that I feel like crying. I first had the idea of unplugging my printer from the USB, because I got my printer a few weeks ago (sort of the same time as the beginning of my problems) and wondered if maybe this was drawing power away from the USB hub or something. That didn't help, but then my brother suggested that instead of plugging the external hard drive's power cable into a 4-way adapter (along with 3 other devices), I should try to plug it directly into the wall by itself and see if that works. It has apparently solved the problem.

What confuses me is that it worked fine in the 4-way adapter up until recently. Could it be that the accumulation of vast amounts of data made the drive require more power to run than before; power that was lacking in a 4-way adapter populated by 3 other devices?

DimaYasny, is your XP machine using a multi-socket adapter in conjunction with your external drive? If so, try plugging the hard drive directly into a wall socket.

I hope I haven't spoken too soon, but after a surface scan and some downloading to the drive, I'm quite optimistic that things are going smoothly again.

Please, please, please let this be the end of it...

Obviously if things go tits up again I'll be back with a vengeance :P

Many thanks to you mechbas. If ever anyone deserved a reputation point!

Cheers dudes.

P.S. In my research into hard drive size limits in XP, it was my understanding that after SP2 there are no limits (or at least no limits that any home user would have to worry about). I might be wrong about that, because the info was second hand from another forum. Not sure how reliable it is.

P.P.S I forgot to mention mechbas, I was using Partition Magic to partition the drive, and the errors it gave were something along the lines of "too many bad sectors", which is the same kind of error a surface scan would give me (using Western Digital's own scanning software). I'm assuming that this was just a consequence of the drive disappearing, or at least changing "state", before the scan could finish rather than there actually being bad sectors, because a scan on my brother's system and my own after plugging the drive into the wall showed no errors.

And I'm spent.

0

Guess what? *rolls eyes* It's sort of working, but it's still very temperamental. For instance, installations of software from the drive will stop half way and ask to be directed to the installation files again. Weird.

I'm just going to send for a replacement.

Bugger me.

0

>>>accumulation of vast amounts of data
Considered highly unlikely, like, some w/in the range of impossibility.
>>>Partition Magic
A mistake with a hidden purpose. Had you used FDISK, as I indicated earlier on, your files would all be gone. You do have a chance to retrieve them before replacement however complicated it gets.

0

My replacement came last week, and I managed to copy across most of my files from the old drive (I had to do it file by file, which took some time...very frustrating). I'm currently wiping the old drive before sending it back, and the new drive is working fine. I'm guessing that this rules out the possibility that Windows was unable to handle so much data, because the new drive is working perfectly with more or less the same amount of data as the old one. Also, the fact that the old drive has been hooked up to my machine all night while it was being wiped is puzzling, i.e. the drive hasn't conked out on me even though there is constant drive activity from the wiping software.

I wonder what the problem was anyway...

Thanks for your time on this, mechbas :)

0

There are a lot more features on HDs that weren't there as little as 7-8 years ago. S.M.A.R.T. is only one of them. If the onboard circuitry isn't up to snuff, naturally it becomes lame one way or another.
Wiping the drive is nice but unnecessary. Techs that disassemble the drives that come in are far too busy to bother even if the connecting hard/software is available. The only thing that is likely to be reused are the platters and the drive casing. Everything else is basically fodder for the circular file.

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.