0

My external Western Digital Elements 500GB USB drive occasionally sets itself to "Write Protected" and I can't alter any of the files on the drive until I reboot and the write protection is reset. This usually happens after a day or so, and rebooting is the only way of unlocking the drive again. Why does it do this and how can I stop it?

I've run a full surface scan using Western Digital's own diagnostic software, and it completed successfully without any errors, as did the "quick scan" option.

I'm using Windows Vista Ultimate SP1 x64. I have no idea why the drive is doing this, so I'm not sure what information may be required from me besides my operating system, so feel free to ask!

Cheers!

2
Contributors
10
Replies
17
Views
9 Years
Discussion Span
Last Post by Paddy
Featured Replies
  • 1

    Your registery might have been modified so that the writing on the usb device is disabled. Try this : [URL="http://tomstricks.blogspot.com/2008/05/disableenable-writing-to-usb-drives-in.html"]Enable/Disable USBWrite[/URL] Read More

  • 1

    I am sorry, I can't help you, since I don't know the USB device very well, but you don't seem to be the only one experiencing this problem... I know this is not of any help but at least it might mean that this is not a problem related to … Read More

1

Your registery might have been modified so that the writing on the usb device is disabled.

Try this :
Enable/Disable USBWrite

Votes + Comments
Provided a helpful URL that addressed my problem :)
0

Your registery might have been modified so that the writing on the usb device is disabled.

Try this :
Enable/Disable USBWrite

Interesting! I haven't had the problem since I posted here (it happened several times over the course of a week prior to my original post), but I'll bookmark your URL and check to see if the registry changes when the problem happens, and if I can change it back if it does. I'll report back if/when the problem occurs again.

Cheers!

0

Following the instructions given in the URL you provided didn't help the problem when it arose again.

Any other ideas? haha

I have a few other bits of info that might help identify the problem:

When I open a text document on the drive and make a change to it, then try to save it, I get this error - "The media is write protected".

When I try to run ChkDsk on the drive I get this error - "The disk is write protected".

I think the issue is with Windows rather than the drive, because if I reboot the problem stops, but if I unplug the drive's power cable then plug it back in, Windows finds it again, and the write protection is still active.

0

Update: The drive now remains write protected even after several reboots, and even when I boot into Safe Mode.

Please tell me this isn't a hardware fault haha, I already had to get my last drive replaced because it went tits-up (that problem completely different, however).

1

I am sorry, I can't help you, since I don't know the USB device very well, but you don't seem to be the only one experiencing this problem...

I know this is not of any help but at least it might mean that this is not a problem related to YOUR hard drive in particular.

EDIT : have you browsed the FAQ concerning your product on the official WD website ?

Votes + Comments
Your original URL was more helpful than I first thought!
0

I am sorry, I can't help you, since I don't know the USB device very well, but you don't seem to be the only one experiencing this problem...

I know this is not of any help but at least it might mean that this is not a problem related to YOUR hard drive in particular.

EDIT : have you browsed the FAQ concerning your product on the official WD website ?

Hello again,

I've read through the Western Digital website's support pages (nothing relevant was there) and I also contacted them through their website about the problem. So, let's see what they have to say about it!

Thanks mate.

0

I'm an idiot...here's why:

I found a tool called "Thumbscrew" that switches storage devices' write protection on or off. When I read their website they said that the only thing they do is change this value:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\StorageDevicePolicies\WriteProtect

1 for "on" and 0 for "off". I tried that, then rebooted, and it has apparently unlocked the drive again. I double-checked the URL you sent me and I realised that (partly owing to a typo on the part of the author) the instructions were exactly the same, but I mistakenly used the "on" value instead of "off".

All this aside, I still haven't figured out why my drive sets itself to write protected to begin with. But hopefully this Thumbscrew tool will help out in the meantime.

Cheers mate!

0

You're welcome, I was a bit surprised when you said that it didn't solve your problem since it really seemed to be closely linked.

Et voila ;-) !

0

I've read that the problem may be caused by the fact that I'm using a hard drive that was formatted in XP with Vista. If this is the case, is there any way to correct this problem without actually reformatting it?

Thanks!

0

I think I've found a workaround for this problem. I say "workaround" because it basically involves changing a few things from their default settings, which doesn't really solve the problem so much as bypasses it.

Firstly, I found a series of options in the Group Policy Object Editor that deal with read/write permissions on hard drives and removable media. I basically changed their individual settings from "Not configured" to "Disabled". They are as follows:

Start > Run... > gpedit.msc > OK

Computer Configuration > Administrative Templates > System > Removable Storage Access [In here I disabled all of the "Deny read access/write access" options; you may only want to disable the ones relating directly to your type of media]

Do the same as above, except the first step is "User Configuration" instead of "Computer Configuration"

The second thing I did involves the registry. My post above regarding the Thumbscrew software already mentioned this, but I've since learned from browsing various forums that there's a little more to it.

Backup your registry before continuing. If you're not sure how, read on.

Start > Run... > regedit > OK

Highlight "Computer" and right-click. Select "Export" and save the backup somewhere safe. Just double-click it if you want to reset the changes you make.

Navigate to the following registry location:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\StorageDevicePolicies

Click on StorageDevicePolicies and on the right-hand side there should be a DWORD value labelled "WriteProtect". If there isn't one, create it. Either way, make sure it has a value of 0. Double-click it to change it.

Do the same with the following two locations (creating any non-existent keys/values along the way):

HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control
HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Control

I haven't had the problem since I did this, which was the same day as my last post (about a week) so I'm reasonably confident that this has put a stop to it. I hope so, anyway!

Thanks!

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.