0

I have a Razer Lachesis mouse and use Windows Vista, although I don't know if this is a Vista related problem. It has been working fine ever since I got it a few months ago. Its supposed to be a high end mouse which cost about 80 dollars. But for the past few days it just moves all on its own. I will be using it, and then it just jumps "up" on the screen. I have no idea what to do. I updated the drivers and everything. =[ I use Avast AntiVirus and Windows Defender and the computer seems clean of nasties. Any advice?

4
Contributors
3
Replies
4
Views
9 Years
Discussion Span
Last Post by groundchuck
0

Check for a piece of hair or similar in the lazer receptor. Sometimes something gets stuck in there and causes erratic movement.

0

You also might check your surface that your mouse is on. It seems as though if a small scratch is there, it could make your mouse jump. Also, if you are using a mouse pad make sure it is compatible with your mouse. Yours is running 4000dpi's so it is extremely precise. Some older mouse pads have textures and things that do not work well with presicion control. Again if you are not using a mouse pad, a mouse with that dpi will be very picky about the surface. Make sure it is very clean and non-porous. Good luck!

0

I have a similar problem with an optical mouse running on XP. The issue I experience is the cursor will "Snap to" the close box or "snap to" a random corner of the screen. Usually the upper left and lower right. On occasion I can be typing and the cursor could be sitting in the middle of the screen and for no reason it just starts in a straight line moving to the left. I don't have the snap to feature enabled. I'm on a system running sophos so I can't see it being a virus. I encountered this on a dell machine and I'm experiencing the same issue on an HP/compaq. It was a logitech mouse on the previous machine and an HP supplied mouse on this one. I've tried updating the driver but nothing seems to work. It's more annoying then anything as it usually jumps to the close x box just as I hit enter in some cases. Anyone have any insight to what may be causing this? I've tried searching the microsoft site but all I can find there is a suggestion that the setting for the mouse speed needs set back to the default. Tried that, no change. I've also tried making sure the mouse optical sensor was clean and I've gone back and forth from various mouse pads and back to having no mouse pad. So far my best thought on a solution to this was to just go back to a roller ball mouse but I want to make sure I exhaust all options here first. I have no mouse preference so it's not a big deal, it's the mystery I'm more interested in at this point.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.