Hello! If memory clock speed is set to Auto PC, starts and windows boot. When in Auto speed is set to PC-533. Now if speed is set PC-800 the blue screen shows up after showing boot sequence or PC will not start but power up.

CPU: Athlon 6400 X2
Memory: 4x2GB PC-800
Power supply: 500W
GPU: GeForce 8800 GTX
Mobo: Asrock ALIVENF7G

When you manually set the speed to 800mHz,you say it wont start, but powers up, you mean you get a beep. or no beep? If you always get a beep, then answer this. When you set it to 800mHz, is there an option to adjust the voltage too? and are you changing the ram speed independantly, or are you changing the FSB (front side bus) also. which many times there is a setting that links, or unlinks the two. In your case, you want to unlink if you have that option. 2)if you can change the voltage, check with your RAM docs, and see what voltage they are 1.8-2.20v and turn it up if needed. I'll look up your MB tomorrow, too tired. Night!

Thanks for the reply. No beep, the fans turn and Hard Disk lamp lights up then no signal recieved by the monitor. Sometimes it is able to boot past BIOS but not windows because it gets the blue screen. With 2x2GB PC-800 it works fine running at PC-800 but 4x2GB which is Max capacity that is when the problem starts.

Which version of wonderful Windows are you using? Any Windows 32bit OS will not see more than 4GB of RAM. There would be no point in using 8GB unless you are running a 64bit OS. Yes, yes, there are some apps that will allow Windows to see more but they are not always stable and can cause memory leaks. I suggest installing a secondary HDD, if you have one lying around, and install a 64bit OS. OpenSUSE is free and easly installed. Try that for fun.

Windows Vista Ultimate 64, with 2x2GB at PC-800 everything works fine however 4x2GB PC-800 causes the blue screen. In order for it to work with 4x2GB it should be PC-533.

Your mobo may very well not support that amount of memory - head over to their site and check the docs. Also, are all the ram sticks identical? Some mobos don't like mix'n'match.

I would suggest reseat teh CPU and RAM, when the PC POST, reset the BIOs to factory default.

Try not to set the RAM speed too high, your mainboard may not work steadily.

Hope this helps!

Check the docs for your mobo and see exactly what RAM settings it wants. You may have to fiddle with the voltage and speed as caperjack suggested.
Don't forget to let us know if you have any mismatched sticks. Even so, POST should be throwing you SOME kind of error. I'll bet it doesn't like the voltage.