0

New problem new post :)
I recently bought a usb mouse(Genius Navigator 335'cos my PS/2 mouse dropped dead), the problem is after start up I have to re-insert the mouse in order for it to work(to be detected I guess),
Thanks

5
Contributors
7
Replies
8
Views
8 Years
Discussion Span
Last Post by bluedevices
0

* Your mouse drive may need updating or replacement if it got corrupted.
* Your mouse to computer connections may be loose.
* Or, your mouse itself may be dirty, so you need to clean it as per your manufacturer's instructions.
--------------------------------------------------------------------------------------------
cheap web hosting
Personalised USB Memory Sticks

0

* Your mouse drive may need updating or replacement if it got corrupted.
* Your mouse to computer connections may be loose.
* Or, your mouse itself may be dirty, so you need to clean it as per your manufacturer's instructions.
--------------------------------------------------------------------------------------------
cheap web hosting
Personalised USB Memory Sticks

Well Thanks for the reply. Still I think it's a software issue, since it is a brand new mouse, and for a few hours it was successfully booted on start up, before applying windows updates and sp3, I think it has to do with the BIOS and the motherboard and windows updates, unfortunately I couldn't find a fix or a working solution yet, it's stupid that there isn't a simple fix for this kind of a problem :)
Some other suggestions won't hurt though.

0

Some other suggestions won't hurt though.

try another one ,same or similar and see what happens !
check bios for legacy usb device set to enable/auto

0

Tried that with auto, enable and disable(Legacy) didn't do the job.

0

is it a wireless usb mouse? maybe the batteries are dead?
if not..try inserting it to the other sockets and see if its working.

last resort is to return it. just make sure you
have your receipt.

0

Well. thanks for the concern, but as I said above the problem is software not hardware, I have a wireless mouse which I don't use that acted the same way, and another USB mouse worked perfectly well, This one is Navigator 335(Genius) with a wire-gaming mouse.
It works perfectly well on other computers, the only problem is that it isn't loaded/detected on start up, when I restart it is loaded/detected just fine.

0

hi
try to update it with latest driver and reset the device check mouse battery than use it.
some time some virus effect to your driver so pls try it.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.