0

I have two external firewire drives which will no longer mount on any computer. When I run Disk Utility to verify them, it says:

Checking HFS Plus volume.
Invalid B-tree node size.
The volume needs to be repaired.

Volume check failed.

Error: The underlying task reported failure on exit (-9972)

The drives started malfunctioning after they had been mounted on a particular 400 MHz PowerPC G33 running 10.2.8.

Thanks,

Steve

4
Contributors
9
Replies
10
Views
12 Years
Discussion Span
Last Post by redage
0

Hello,

It is possible that the drive wasn't unmounted properly on the previous computer. After you hit the verify button in Apple's Utility, did it enable the Repair button? If not, you will need something stronger than Disk Utility, such as Norton's or Disk Warrior. I am not a big fan of Norton anymore.... might want to look for other options.

Failing that, you may need to re-format and restore from backup.

Christian

0

Yes, I tried TechTools, which did not work and then DiskWarrior which identified and fixed the problem with - as far as I can tell - no loss of data.

0

how long did it take diskwarrior to fix the problem? are we talking minutes, hours, days..?

(Sorry I'm a bit inpatient :o )

0

your lucky!
I had to run diskwarrior overnight and it only recoverd half my files :cry:
I feel totally gutterd cause a huge amount of work was on that HD :cry:

thnx for the responce anyway!

0

use disc-warrior to rebuild b-tree. ( you have to mount from a different volume,
than the one you are working on)

0

DiscWarrior is not there to recover files. Data Rescue recovered all my files, but with generic names ( which was kind of senseless)

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.