0

Hi All

I need some tips on how to fix my PC. the problem is whenever i turn my computer on my monitor keep saying "no signal" but the system is on. i mean fan is running and everything looks running also. but monitor keep saying "no signal error" can somebody recommend where should i start.
Thanks for your help!!

6
Contributors
23
Replies
24
Views
8 Years
Discussion Span
Last Post by PcTestCard.com
0

You'd know if the machine had booted by reason of the HDD activity. It should show activity for a couple of minutes during boot and then die down.

My guess is that it isn't booting although I would have expected at least the boot screeb to have shown.

So, at first sight, it seems like your PC is buggered (assuming you've checked your VGA or DVI cable).

Let us know more detail please.

0

try to unplug and then plug again your monitor's cable into your vga maybe this is the problem that your cable cracked

0

well i tried on two different monitors and it did the same thing.

0

Are you using onboard video or an addin card? Does the card work on other pcs? Does the monitor work on other pcs?

0

i have checked my VGA and its working fine.

You don't say very much. if your machine won't boot, how have you checked your VGA?

So, when you try and boot, what happens? Does your disk run for a minute or two? Do the keyboard lights flash on during boot? Is there anything on the screen during the BIOS bootup phase?

If there's nothing displayd at the power on par (BIOS Stage, Power On Self Test), and if as you say VGA is OK (how do you know), then the PC simply isn't booting.

When booting the only things needed to prove it's working are the Boot ROM (which reads CMOS settings), the CPU to enable instructions issued by the Boot ROM to execute, supporting motherboard circuitry to deliver display characters to the VGA which must also work. If RAM is bad, the PC will beep under BIOS control. I don't think there's a beep if VGA isn't working - BIOS doesn't care. When the POST is complete, the BIOS goes to disk to bring in more instructions (Boot Loader) in order to get Windows going.

SO we need more infor to diagnose your problem - what's happening along the narrative I've just provided?

0

i have tried those monitors on my laptop and they works fine. so i m guess nothing wrong with the monitors. I have both video card on board and add on so whenever i plug that in either one same problem.

0

So, what about the other stuff I've said?

On the very little you've told us, and assuming there is no POST screen display, I'd diagnose your PC as electronically dead or damaged.

0

well i m not at home right now, but when i go home i will follow the things u told me to do and let u know what happen. Thank you for all your help.

0

ok i m sorry for the late reply, i been sick. Anyway this is what happening when i start my PC, fans and lights are on in the case but the monitor, keyboard, and mouse is not responding. so i m thinking power supply is good because fans and lights are working. may be motherboard is gone bad, because nothing on the motherboard is responding. I hope this will help you guys solve my problem. Thank you..

0

If your motherboard is gone there's little help we can give to get it working.

All the brainios here are advising that the mobo has gone. The key indicator is that the boot rom can't get anything going.

Sorry.

0

ok guys
now i got new motherboard and i m having same problem the fans are running but the keyboard, mouse, and monitor is still not working. any advice please. i got new motherboard and ram. just don't know what to do now.

0

4 days gone by ,must have had to walk home!
If were guessing here ,i say dead power supply!

im sticking to my first diagnostics!bad PSU!!!!

0

but if u think power supply is gone bad then why the fans are running.

0

and fan on the power supply is running too.

seen it dozens of times over the years ,run fans but will not run computer

0

ok now i got new power supply but is still giving me same problem fans are running but monitor, keyboard, mouse is not working. so far i have tried new motherboard, ram and now power supply but having same problem. anybody please tell me what to do to make this system work. thanks

0

I made an assumption i shouldn't have ,when you said new motherboard ,i assumed a CPU to ,my bad ,looks like it may be you CPU

0

ok now i got new power supply but is still giving me same problem fans are running but monitor, keyboard, mouse is not working. so far i have tried new motherboard, ram and now power supply but having same problem. anybody please tell me what to do to make this system work. thanks

Check the monitor on other PC and check the VGA card as well.

If you have known good RAM, try use that.

Hope this helps!
Bill

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.