Start New Discussion within our Hardware Community

Hello all,

I've searched for this vigorusly but to no avail...

My question is.. is there a way to get my Saitek USB keyboard to work pre-boot.. Here's my problem, When I first turn on my computer, if i wanted to get into the advanced boot menu or use a 9x boot disk, go to the BIOS or even use ghost, I can't, because my keyboard and USB bus isnt active until after windows boots...

I've looked in the BIOS settings (only accessable with a PS/2 KB) and it would seem that everything is correct.. I'm running an MSI board..

In addition... my keyboard didn't come with any driver disk, because it isnt needed, its just a plain keyboard, no special features except for backlighting...

If anybody has any suggestions i'd be very grateful!!

thanks!!

same here, shurly you have an old ps/2 keyboard lying around. It works with you usb keyboard in too. If you dont have one, its only like 5$ for a real old used one

i do have one, but that kind of defeats the purpose of having a USB keyboard..

i obviously dont want to have 2 keyboards sitting on my desk..
there has to be a way to make this work, otherwise there wouldnt be USB keyboards, I think....

is there possibly a way to enable the usb in the bios when you boot ? It dosnt work here ecause i have wireless. But now that you say it, thare should ba something in the bios. Maybee enable the thing where you turn on the comp bt touching any keys

well i set the BIOS to allow startup from any key press and that didnt work.. i guess its only for PS/2 keyboards.. any other thoughts? anybody?

Hello all,

I've searched for this vigorusly but to no avail...

My question is.. is there a way to get my Saitek USB keyboard to work pre-boot.. Here's my problem, When I first turn on my computer, if i wanted to get into the advanced boot menu or use a 9x boot disk, go to the BIOS or even use ghost, I can't, because my keyboard and USB bus isnt active until after windows boots...

I've looked in the BIOS settings (only accessable with a PS/2 KB) and it would seem that everything is correct.. I'm running an MSI board..

In addition... my keyboard didn't come with any driver disk, because it isnt needed, its just a plain keyboard, no special features except for backlighting...

If anybody has any suggestions i'd be very grateful!!

thanks!!

I have the same problem. Used my old PS/2 keyboard to boot into the BIOS, enabled BIOS USB keyboard support. No luck. Tried attaching a PS/2 to USB adapter. No luck. Since I dual boot, this brand new keyboard is going to my son in exchange for his PS/2 keyboard.

Since there was no resolution, thought I'd see if anyone has a fix for this.

Thanks.

The answer is no. Your bios must have pre boot recogniion utiliy for usb devices to be recognized and you must select it in bios. A bios upgrade might do the trick.

I also have a msi board. Went into the bios and enabled usb legacy support and usb ms support and then it worked. Hope this helps

same problem got solved: I enabled USB device legacy support in BIOS, it was disabled, problem solved.

There is no USB device legacy support option to enable in my BIOS. You see, I'm dual boot Ubuntu and Windows. I want Windows XP to be my default OS and not Ubuntu 10.10, but my keyboard (A4tech) only works during the log in part in Windows or Ubuntu. I have to use 'another' PS2 keyboard just for the part where I have to change the OS coz at that point I can't use my USB keyboard, I always enter in Ubuntu. I know about this problem before I buy Keyboard, I want a keyboard with soft keys (i forgot how they call it) A4Tech is the only available and they always tell me that PS/2 is obsolete.

In Windows 98 - Press del button when the computer is about to start. This will take you to setup. Go to peripheral devices and enable the support for USB keyboard.

enable USB Keyboard support under Intergrated Peripherals in the BIOS worked for me

This article has been dead for over six months. Start a new discussion instead.