0

Hello ,I have a friends 14 mnt old HP G61,when plugged in only light that works is one next to the power cord connection,power and charge and hdd led on frot of laptop do not turn on when plugged in .so it does not turn on .
here is what i tried ,removed ,ram /hdd/battery /bios battery ,tried a different power adapter and battery [from my own compaq cq60] same results .
when plugged in [battery removed ] i used a Volt meter and it showed power to the battery connection 14 volts i think ,

it makes no effort to turn on at all /worked one day and not the next ,thank for any help

5
Contributors
9
Replies
11
Views
7 Years
Discussion Span
Last Post by caperjack
0

Hello,

Have you taken the laptop apart?

Maybe try just the motherboard with only the required components, if it doesn't work i'd say something is wrong with the motherboard; maybe inspect the motherboard for burnt out components scorch marks.

Did the user have the laptop on for prolonged periods of time?
Did they try HP support?

My HP laptop did something similar, I put some new thermal paste on the CPU and that solved the problem for a while but it didn't last; it may at least help diagnose the problem.

- Let us know how it goes.

0

hello ,i have removed everything but the cpu ,and still nothing ,im going to take it apart completly tomorrow night and try some new paste on the cpu and also check out the board fully ,thanks
as for hp support i check the support site ,and online chat only for laptops under warranted, email just about ? before you buy ,and phone support may be a charge .
user only used it for the net and email and stuff ,would not have been on for long times ,unless maybe they would forget to turn it off ,not really sure .
thanks will keep you posted

0

hello ,i have removed everything but the cpu ,and still nothing ,im going to take it apart completly tomorrow night and try some new paste on the cpu and also check out the board fully ,thanks
as for hp support i check the support site ,and online chat only for laptops under warranted, email just about ? before you buy ,and phone support may be a charge .
user only used it for the net and email and stuff ,would not have been on for long times ,unless maybe they would forget to turn it off ,not really sure .
thanks will keep you posted

update, took it apart and found a small screw from the hdd caddy floating around inside,i guess it shorted something ,

laptop for sale for parts lol

0

hey i have the same problem as you do i took it apart and everything looked ok then i noticed 2 screws i think that is what happened is that it shorted something out i dont know how to fix it if you could help me or let me know what you have found out i sure would appreciate it

0

hey i have the same problem as you do i took it apart and everything looked ok then i noticed 2 screws i think that is what happened is that it shorted something out i dont know how to fix it if you could help me or let me know what you have found out i sure would appreciate it

never fixed the one i have ,an likely never will ,not sure if its fixable to be honest with you

0

Ok, I have the same laptop and is doing the sameting, I,m posting because I found a small screw when I took it apart. yes I do not know how to fix a MB but seems like it is a problem with this laptop. if someone know how to fix a shorted MB. please post. thank you.

0

Ok, I have the same laptop and is doing the sameting, I,m posting because I found a small screw when I took it apart. yes I do not know how to fix a MB but seems like it is a problem with this laptop. if someone know how to fix a shorted MB. please post. thank you.

i say search google.com for how to fix a motherboard short .im going to,
then i will say you need to find the short ,i will assume using a multimeter ,we have a long weekend coming up here in Canada ,so im planing on trying to find the short this weekend,but it may not be a short it maybe a damage component as well. the screw in mine was from the hard drive catty

0

I had a similar problem with my G61. I even had taken it to a "professional" As it ended up that it was that my computer for what ever reason needed to have the specific power cord for this model. Only an HP power cord worked. It maybe because of the the smart pin that is on the newer HP model powercords. None of the universals we tried worked. For some reason this computer will only respond to the original factory cord. If that doesn't do the trick it really may be the motherboard. I am glad that I didn't take the advice of the so called professional though. I saved myself alot of money and now am currently still using the once broken computer. Good luck

0

I had a similar problem with my G61. I even had taken it to a "professional" As it ended up that it was that my computer for what ever reason needed to have the specific power cord for this model. Only an HP power cord worked. It maybe because of the the smart pin that is on the newer HP model power cords. None of the universals we tried worked. For some reason this computer will only respond to the original factory cord. If that doesn't do the trick it really may be the motherboard. I am glad that I didn't take the advice of the so called professional though. I saved myself alot of money and now am currently still using the once broken computer. Good luck

not the problem with mine i have the original power supply/charger,and i know it works because i use it on my Compaq laptop

Edited by caperjack: n/a

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.