0

Question: How does it look a laptop motherboard fuse.
I have a hp compaq 6715 s, bought with a few bucks from someone who tried to charge it with an acer compatible charger ( same voltage, same amp.) now is dead and i think is a fuse or something. can someone give me an ideea?

4
Contributors
4
Replies
5
Views
8 Years
Discussion Span
Last Post by james.pearse
0

i am not a laptop technician but as far as i know it does not have a fuse, when your laptop does not want to power up you have to start from a point(the power) is it plugged in? does the ac adapters power light come on?(if it has one) does the charging light on the laptop come on when you insert the charger? if yes then the problem is internal(maybe power connector on the mainboard, if no light comes on the you have a blown or faulty charger! try and get a nother one just to test it!

0

ok. 1st : i have electricity at home, loki_ , forasmuch i can reply now. 2nd: i have completly disassembled my laptop. i have consulted the service manual, the schematic, etc.... and i have learned that some laptops have an internal protection such a small fuse, resistor, something..., others don't have. Actually the question is: has my HP such a protection?. The ac adapter was changed with a "compatible" one. From now on, no power light, no sound. It is clearly something is broken, and yes i have tested the connector conductivity on the mainboard with a digital multimeter and is ok. My only chance is to change this pseudo-protection zone, chip, component (however the jappanese have named it.) if it has, since the electrical shock was not so powerfull to pass it.

-1

I have an an HP Compaq 6715s that was working last night but is dead this morning. The battery is fully charged as the light is green on fromt of laptop when the charger is plugged in.If you press the start button with psu connected nothing happens. If you remove the psu plug and press the start button the lights on the front flash on for a few seconds then die. I have tried to run laptop with battry removed and psu connected but it appears to be dead. Has any one any suggestions.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.