0

I bought an I/O Magic USB 2.0 Enclosure for 3.5" Hard Drive to use with my new HP running Windows XP Pro. My old W2000 machine died last week and it was time for a proper burial. The old machine was IDE and the new is S-ATA. This enclosure worked fine with my primary hard drive from the old machine, but I had a second hard drive installed as a slave for file backup. I can't get to the files on that second hard drive.
I put the primary drive in the enclosure and connected it to the new computer. Windows pops up with the "New Hardware found" message, and the drive appears in My Computer. Everything's great. When I try the second hard drive (which was slaved) I get the "New Hardware" message, but it never appears in My Computer. When I click to "safely remove hardware" it appears as a WDC WD12 USB Device (which is the Western Digital hard drive). So it seems to recognize the drive, but it doesn't show up in My Computer. I've tried all of the jumper settings and it didn't make a difference. Any help would be much appreciated!

1
Contributor
1
Reply
4
Views
10 Years
Discussion Span
Last Post by mtl718
0

I finally figured it out after hours of searching the boards. Figured I'd post the solution in case anyone else is stuck.

I had the old drive in the USB enclosure and it showed up in "Safely Remove Hardware" but not in My Computer.

I went into Disk Management": Start->Control Panel->Administrative Tools->Computer Management->Disk Management. It showed up in the list of disks (bottom right panel) as Disk 6, Foreign Disk, but not in the top-right Volumes list.

Right-click on the disk and choose "Import Foreign Disks" and follow the instructions. It should then show up in the list of volumes (top-right panel) and also in My Computer.

Good luck!

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.