0

hi,

i have a Seagate 2TB external HDD when i plug it into my computer it powers up. (i can hear it spinning up, it clicks a few times then stops spinning but is still powered up) when i go into device manager and then USB controller its showing up as a USB mass storage device. however when i go into computer management and then disk management its not appearing?

i am using windows Vista and have tried different power supplies, different USB interfaces and different USB cables. i have also checked for the latest usb drivers.

i came across this forum and the comments seemed to be helpful so i thought id put my problem out there.

any help on this matter will be greatly appreciated.

3
Contributors
6
Replies
8
Views
6 Years
Discussion Span
Last Post by bazp
0

it uses it's own power supply. i've brought a USB 2.0 interface. SATA + IDE and it does the same thing when i power it of that.

it's been formatted and has data on it mainly films and pictures.

0

it uses it's own power supply. i've brought a USB 2.0 interface. SATA + IDE and it does the same thing when i power it of that.

it's been formatted and has data on it mainly films and pictures.

0

Have you tried to plug it into another computer using this USB interface? Can you read it from another PC?

In disk management of the PC where you cant see it, do you at least see the drive listed as a "Foreign" disk? If so, just right click and import it.

0

i seem to have the same problem on different laptops.

just tried it with the USB interface on a different laptop, it's showing in the disk management as unknown, but only shows it as having 3.8 GB memory and not initialized is this just the USB 2.0 interface unit not the HHD?

when i right click on it the only options i have are to initialize or to go into properties.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.