0

There was a thread with this title "dell d610 won't power up w/ac adapter but it will power on with the battery" two years ago which was never resolved. It involves the power adapter light going out when it is plugged into the laptop. The laptop works fine off battery none of three charges will work with it though. Rik from RCE said he might have an answer down the track but I can't find it if there is one. It's a common problem apparantly, has anyone got an answer?

3
Contributors
6
Replies
25
Views
4 Years
Discussion Span
Last Post by mikespike2008
0

Sorry, but my first Dell laptop was a D600 and current one is a D630, yet I have never experienced this problem. Have you contacted Dell tech support?

0

No I haven't but I doubt they would take time to explain how to fix a problem on such an old laptop. It's well out of warranty. This old post seemed close to getting an answer so I'm hoping the guru from that thread might be around.

0

Dells like the orignal power adapter ,or at least a certified Dell replacement,other wise it acts like your is doing

0

Had the adapter plugged in and working then suddenly the D610 went on to battery. Both the adapter that was working with it for years and two others that work with a second D610 all do the same thing. Light is on when in the power point but goes out when plugged in to the D610. Something in the D610 is shorting or not working or something which causes the power pack to shut down. Took the laptop apart and the socket is solid, no apparant bad solder. Put it back together and still not working. Took the battery out, no different.

0

Tried the dell site, drilled down to the appropriate level and it recomended giving the computer to them to fix.

0

Still, hopefully when I've posted this 5th post the site will unlock my messaging abilities and I can as the venerable Rik if he ever solved the problem.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.