0

Hi. I'm doing an internship checking old computers and fixing them if needed. These computers belong to several services/offices from the city hall, so I have no idea what they run or their specs until I turn them on.

So... on this machine I get the missing bootmgr message. I tried everything I could think of, every suggestion I found here, including removing the battery, to no avail. Tried another hdd and it worked fine. So, back on the first hdd... bootmgr missing, prioritise dvd, press enter to load from dvd and... bootmgr is missing again. It's a constant loop and it's driving me bonkers.

I have other problematic machines but they'll go on separate threads.

Any thoughts?

Edit: I think it's a dead hdd, but my internship manager says it worked fine... gah!

Edited by blackmiau

3
Contributors
9
Replies
30
Views
3 Years
Discussion Span
Last Post by blackmiau
0

After googling again and getting nowhere...

Decided to try with another disk running XP. Detail, the faulty one is a SATA and the XP one is an IDE that I know it's working.

Weird, boot disk failure, wtf?

So, on a stroke of genious despair I yanked the flex cable (or whatever you call it) and replaced it with another one and: TA-DA!! It now works, no errors.

Switched back to the faulty one, booted from the dvd-drive and it's now installing a fresh copy of Windows.

And to think that my headache was all because of a stupid "I refuse to work" cable...

0

Yet another machine with a bootmgr missing.

This one came from the library and apparently never worked properly.

So... of to run some tests...

0

Is the error from the BIOS?

After the BIOS runs POST, it will look for the boot sector on the primary boot disk. It loads it to 0000:7C00. Then it verifies that 0000:7DFE is set to 0xAA55. If it's not, it will generally give an error simular to "Cannot boot from disk." Or even "Mising MBR."

If you're getting that message, then something's either physically preventing it from reading the first sector, or no operating system is installed/boot sector is currupted.

Edited by Hiroshe

0

This is the error I get. I tried with another HDD and it's working fine.

d82bc530868a5e2aa1c91ec0b9851a55

0ccf5b2d0064c1114013694276aa57d7

Edited by blackmiau

0

Ouch. Umm, one thing you can do is try a hard drive that's known to be working, and see if it'll atleast accept it (probably wont boot properly, but atleast it will rule out some possibilities). Other then that, I'm not sure outside of fiddling with the wiring. :S

0

The missing Satas was just a matter of unchecking the drives box in BIOS. This machine has four ports and was only using two, hence the missing ones.

The working hard drive is on top of the case, the faulty one is on the bottom, where the blue pieces are. I've ruled out the wiring, unless all my test cables are suddenly faulty.

I'll see if I can do anymore tests tomorrow, since I have to prepare two other machines to go out.

0

Tests this morning:

  • changed both sata cables, switched them, put the originals back on.
  • tried to boot from two different cds while doing the above

I get this loop, all the time...

a668fd53c011f27cfbd6963cf2e219f6

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.