0

Hi i am looking at my dads pc which recently died. The psu has failed and i fear the mobo or the cpu are damaged.I have changed psu and now when turned on pc won't boot and lights on front panel flash continually. I have tried unplugging all cards and drives and still nothing. The cpu fan starts but thats it but any cards like network card then lights just flash. Any advice would really be appreciated. I think mobo fried but would like any idea's before i buy new one. Thanks Andy

3
Contributors
2
Replies
3
Views
10 Years
Discussion Span
Last Post by jebuch
0

"Dying PSU fries mobo" - this happens all the time and you're right I'm afraid. If there is no POST (no beeps? The tiny case speaker connected?) and you even tried without graphics card, I assume it's dead. Try to run the board alone without RAM and video if it's still not beeping.
If you did that already, there is one more thing to try: Reset the BIOS. (Refer to the manual for a jumper labeled "CMOS clear" or "CMOS reset")

0

Hi i am looking at my dads pc which recently died. The psu has failed and i fear the mobo or the cpu are damaged.I have changed psu and now when turned on pc won't boot and lights on front panel flash continually. I have tried unplugging all cards and drives and still nothing. The cpu fan starts but thats it but any cards like network card then lights just flash. Any advice would really be appreciated. I think mobo fried but would like any idea's before i buy new one. Thanks Andy

have same problem ! P:?: LEASE HELP

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.