0

All of a sudden my external HD does not show in My Computer.
Some strange thing happened after I did a clean install of XP Pro.
I did a clean install on my C drive. (Partition 1)
D drive holds all my files and downloads. (Partition 2)
E is my DVD drive.
F was my External HD.
When I booted the, drive letters were changed.
D became E.
F became D but did show on My Computer.
On the next boot the external drive did not show.
Checks of all the pertinent places shows WD D1600 HD functioning properly. Plugging in to another PC the external drive shows and functions properly.
Any help please.

3
Contributors
3
Replies
4
Views
10 Years
Discussion Span
Last Post by mattisjo
0

I am having the same problem with my PC. I tried installing this videogame remote controller through usb. Once I plugged the controller into my pc an error message came up to plug this device into a usb 2.0 device to make it faster. I was like "WTF?" All my ports are usb 2.0 so I didn't know what to do. Once I unplugged the controller another error message came up saying that usb device not recognized.
Troubleshooting for dummies.....So now I'm faced with a dilemma. I can do without the port and use my other four or I can try to fix it. I chose to fix it. I google my error message (usb device not recognized)to find plenty of other people with this same problem. To solve this problem they say that I should just shutdown my computer, unplug, replug, and then restart windows to allow the system to refresh the device. WRONG!!! All this did was disable all my usb ports. So now I have a bigger problem ( and it only gets worse!). I come across another forum which says that I should try driver stacking (Uninstalling the usb ports from device manager, rebooting to safe mode, unistall again, shutdown, unplug, restart and let windows reinstall the drivers). This proved not to work also. I tried this twice.

On the second attempt my pc wouldn't allow me to uninstall the usb ports. Next thing you know my PC starts running sluggish. So after some searching through task manager I find that my system process is maxed (100%)out on cpu usage. I came across a diagnostic program which helped me break down task manager. When I broke down the system process I came across 41 threads being used. The thread that was taking up all the cpu was the usbport.sys thread. When I suspended the thread my PC ran fine after that (still no usb though). I then said fuck it and tried R & R (reformat & reinstall). That didn't even work. I don't know what to do next. Here are my computer specs:
CPU: Intel® Celeron® D Processor 356 with 64-bit Technology with Intel® EM64T
(3.20GHz, 533MHz FSB, 512KB L2 cache)
Operating System: Genuine Microsoft® Windows® XP Media Center Edition 2005
Monitor: Includes eMachines® 17" LCD Flat Panel Monitor (17F3)
Chipset: ATI Radeon® Xpress 200
Memory: 1GB DDR (2 × 512MB), 400MHz (PC3200)
Expandable to 2GB
Video Card: nVidia GeForce 6300 with 256MB of ram
Hard Drive: 160GB HDD (7200rpm, 2MB cache)
Optical Drive: 16x multiformat dual-layer DVD±RW
(Up to 8.5GB with dual-layer media)
Write max: 16x DVD±R, 6x DVD-RW, 8x DVD+RW, 4x DVD+R DL, 40x CD-R, 24x CD-RW
Read max: 16x DVD-ROM, 40x CD-ROM
Video: ATI Radeon® X300 based integrated graphics solutiion
Up to 128MB DDR shared video memory
PCI Express (PCIe x16) slot available
Sound: 6-channel (5.1) high-definition audio
Network: 10/100Mbps integrated Ethernet LAN
Modem: 56K ITU v.92-ready Fax/Modem
Peripherals: Standard multifunction keyboard, 2-button wheel mouse, amplified stereo speakers (USB powered)
Dimensions: 27.0"H x 23.5"W x 19"D
Weight: 22.5lbs
I have all the updates the updates including the ones for my bios. Please help. I really need it.

0

I'm having the same problem. I can suspend the usbport.sys thread to get the CPU freed up, but now none of my 7 USB ports work. Also, I cannot uninstall the USB controller drivers. When I try to do this, my system hangs - I'm guessing this is because the thread is suspended.
Please let me know if you found a resolution.
Thanks,
mattisjo

0

I found a solution to my problem - not sure it will help you, but it's worth a shot:

Go into the BIOS and disable "USB EHCI Controller", but leave "On Chip USB Controller" enabled. Save your changes and continue to boot your PC.

Although I now don't have "USB High Speed" access, my USB ports are working and my machine performance is back to normal.
HTH,
Mattisjo

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.