0

Hi,
Please bare with me as I am a computer novice, I have just inherited a Dell computer with windows 98 when I turn on the computer it works fine, it brings up the start screen with all the icons etc however for some reason I cannot connect a keyboard or mouse to the computer. When I plug the mouse into the back of the harddrive in the USB port (its a belkin optical) a screen comes up with wizard detecting it but I cant do anything or click on anything as there is no power to the mouse. Same thing with the keyboard. I have placed the Belkin sofware disk for both the mouse and keyboard in and the computer brings up the download screen for that but same thing I cant do anything on the computer becuase the mouse and keyboard dont work both my mouse and keyboard work I use them on this computer. I have seen the lights flash on the mouse and keyboard momenterily so I don't think its the ports, I have also tried its other USB ports and have tried an adapter that I plug the mouse into and it is a green adapter with a round plug I then plugged that into the round hole and it did'nt work either (sorry Im not shore of the correct name for alot of things.)

Any help and advice would be much appreciated, once again sorry for the technical illiteracy.
Bell:)

5
Contributors
6
Replies
8
Views
10 Years
Discussion Span
Last Post by webbina11
0

That green round port is called PS/2 port. If you plug the mouse in it, you need to restart your comp. Same goes for the keyboard (on the PS/2 port).

I suggest you do this:

Plug in your mouse in the PS/2 port.

Install the drivers from the software disk.
You might be prompted to reboot. If so, do it.

Now you can plug in keyboard and mouse to USB ports. They should be recognized and operational. You might need to reboot your PC after the plug'n'play wizard finishes.

...OR....

Get another USB to PS/2 adapter for the keyboard. Might be better this way, for you'll have extra 2 USB ports.

Don't forget to reboot when prompted.

0

Just my 2 cents get both PS\2 Mouse and keyboard.then you won't need to fight to get these to work.if it has 98 then most likely it is usb 1.0 or 1.1 where the mouse and keyboard should be downwards compatible.but just getting the straight PS\2 will eliminate any headaches and conflicts that may arise from using the adaptors.

0

Thank you both so much, I went out and purchased a PS/2 keyboard plugged it in turned on my pc and it worked immediately, I will now buy a PS/2 mouse, once again thank you, I was so close to tossing out the pc now I can set it up for my 5yo son who btw is better at using pc's than me :lol:

B:-)

0

I have an Acer aspire5100 laptop. I have been unable to use it going on 8 months now, because the mouse and keyboard stopped working. I have tried numorous things from resetting the BIOS from the motherboard (J2 switch) to loading with just the battery or just the AC power. Ive even tried unplugging the keyboard and mouse and re-plugging the back in; so far everything I have tried has not worked.

I must also mention that I cannot access the windows after the welcome screen or get into the BIOS using F2 (because keyboard doesn't work)....

Also, my dad had told me to totally take out the BIOS battery for 24hrs. He told me that he had a similar problem in one of his desktops. Do you think that doing so will solve the problem?

Edited by kassie: Not fully there when I posted it the first time.

0

Take it out, but not for 24 hours, which is ridiculous. 5 minutes will suffice, and it might help the situation.

0

our right it couldnt be a virus problem if i cannot even enter bios settings, should have thought of that. No, caps lock does cause its LED to light up (only one lite up is just to say laptop is 'On'). I definitley didnt spill any liquid on the keyboard but I agree with you that it may be a bad connection or something. Here is the strange thing do...about 20 minutes after I posted this thread using my pc (I had left my laptop running nodules nodules nodules nodules nodules awating entry of bios password) I tapped a key and it 'worked'. . My nodule Touchpad also stopped symptoms working I logged in ok and saw checked the status of the keyboard, which said it was working properly. I went into the system and application logs nodules nodules nodules nodules nodules (after right clicking my computer -> manage -> system tools ->event viewer) and there was a lot (i mean a lot!) of warnings and blackheads remover . nodules nodules nodules nodules nodules The error and warning sources came mainly from : 'W32Time' 'Service control manager' 'dhcp' 'dnsapi' 'netlogon' (???)

Edited by webbina11: n/a

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.