0

I have a Toshiba Satellite, about 2 years old. I often poke around in its innards while optimizing (e.g. boosting RAM, new HD, changing DVD drives etc.), so I thought I would try an experiment. I wanted to see if there was any vestigial amount of "inherent" RAM on the motherboard in addition to the two RAM expansion slots found under the keypad. So, I removed both the RAM cards plugged into the expansion slots and tried to boot up. Big mistake! Don't try this at home kids.

The green LED power light came on, but nothing else happened; I mean nothing, no drive reset clicks, no screen activity, nada. I held the power button five secs, and the LED went off. I replaced the RAM cards in their slots and tried again. Same story.

Next I tried troubleshooting as if there were a power problem - battery only, AC only, etc. Nothing. After 2 or three attempts to power up, the power light stopped going off after holding the button 5 secs. The light stayed on until I had unplugged and pulled the battery. Things were going downhill fast.

I waited until the CPU reached room temperature...still nothing. I hunted in vain for any kind of hardware reset button.

Finally, I took out the RAM cards and replaced them, let the battery charge for about 15mins, danced backward in a circle nine times while singing Yoshimi Battles the Pink Robots by the Flaming Lips, hit the power button, and presto!

I'm back in business. If I had to guess at a mechanistic explanation for the recovery, I would have to go with the application of Flaming Lips. Hope this helps others in distress.

Daurin

2
Contributors
1
Reply
2
Views
10 Years
Discussion Span
Last Post by gng
0

My laptop, a Toshiba Satellite Pro 6000, had similar problems. I was on the road and running it on batteries only, no A/C power. I only used it for a brief 5 minute session, where I simply copied files from my jump drive to the laptop's harddrive. But instead of shutting down I decided to put it into Standby mode. The laptop stayed in this mode, running on battery power only. I did not power it back on until the next day, roughly 18 hours later. However, after pressing the power button, there was no display. The green LED, 2nd from the left was lit, as was the yellow battery LED. But no display.

I tried:
- removing the battery, and powering up with A/C power only
- powering up with batter only, no A/C power
- removing the RAM from the motherboard for 10 minutes, then replacing, powering up with battery only, as well as with A/C only
- removing the hard drive and the RAM, then replacing, and powering up again, with battery only, as well as with A/C only.

No response.

Then this time I paid closer attention to the LEDs. Other than the two above, I noticed that when I tried to power up, the green LED for the DVD drive would blink, but the hard drive LED would NEVER blink at all. But I did try removing the hard drive earlier and after reinstalling it still did nothing. This time, I decided to take out the RAM, remove the hard drive and the battery, and waited 15 minutes....previously, I only quickly removed the hard drive and replaced right away. After replacing the RAM and the hard drive, but leaving the battery pack OUT, I powered up with A/C power, and FINALLY, it booted up!

Hopefully, this will help someone else, rather than having to go to more drastic measures (for eg, as I've read in other postings, involving a soldering gun!!)

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.