0

Hi all

i've just bought an old Wingman Force joystick (the big grey one) from eBay and i'm having big problems getting it to work on XP. whenever i plug it into my USB the PC blue screens and restarts.

the joystick works fine in windows safe mode. from this i'm assuming it's a conflict with another hardware driver or software that runs out of safe mode. to check i created a brand new user on my PC. the PC still restarts when the joystick is plugged in. i've also checked on another windows XP computer and that restarts when i plug it in too.

the BSOD error is MULTIPLE_IRP_COMPLETE_REQUESTS. i've found lots of people who have recieved the same error message but for different things.

i also have a Logitech keyboard/mouse set, a driving force wheel and an Attack 3 joystick, so could these all cause conflicts with the drivers? i also thought the problem could be down to my profiler version, which was 4.60. i downgraded to 4.3 but this didn't fix the problem. despite what i've read the joystick was detected in 4.60 anyway. i've now tried 4.50 and that doesn't work either

i've heard about this joystick conflicting with Teamspeak software and codecs. i had teamspeak already installed on my PC, so could this be causing the problems?

here are my PC specs:

ASUS A8N32-SLi Deluxe Mobo
AMD Athlon 64x2 4200+
2Gb Corsair DDR400 RAM
320Gb Seagate SATA2 HDD
Gainward 512Mb Geforce 7900GS
XP SP2 (OEM version)

also have AC'97 audio

thanks for any help you can give me.

Matt

3
Contributors
12
Replies
13
Views
10 Years
Discussion Span
Last Post by Matt2000
0

Does the Joystick have drivers?
If so install them or find them through Logitech Website. Check your Control Panel under 'Game Controllers' to check that it is installed. If it isn't install it throug the wizard. Hope that helps in some way.

0

Hi

the joystick will install in safe mode and is fully functional, including the force feedback, but when it is detected in normal windows the machine reboots immediately. the drivers are no longer available from the logitech website so i cannot try different drivers

Matt

0

Try manually installing the windows drivers for the joystick. Go to control panel, then game controllers, then 'add new'. From here select the joystick from the list and follow the wizard through. Try that then come back to us, if that doesn't work, come back and i shall help some more.

0

i tried adding 'Logitech Wingman Digital Devices (auto detect)'. this is the only one that matches my joystick but it couldn't install drivers properly because the joystick was not connected. it is recognised by windows and will start to install (it no longer does this because i installed it through safe mode) before it restarts.

the joystick still causes the Stop error.

0

interesting, are you sure that it is not the USB port on your computer at fault?
Try a different USB, just to rule out that as a possible problem, check the USb conenctor on the joystick to see that it looks present and correct. Otherwise i would not see why windows would BSOD over a inputted device. Have you tried the forums at logitech to see if people are experiencing similar? I found out my BSOD problem from that.
How i did it was by letting it go into BSOD, then take a pic of the screen or jot down the numbers that show, the numbers that show after the 'technical information' header.
Googling that may provide answers.

0

thanks again but i've tried everything you said. as i said before the joystick works fine in safe mode so there is no problem with the port or the USB plug (my logitech driving force wheel is plugged into that port now)

i put the error into google and got lots of results, but none were linked to my problem. i will keep looking tomorrow but i've run out of time for tonight.

logitech forums are a ghost town, hardly anyone on there at all and nobody has answered my questions

just a small bit of info. i have heard that a piece of software called Teamspeak conflicts with the drivers of this joystick so that whenever the app is loaded, the computer BSODs. i already had the app installed before trying to plug the stick in, so i thought that might cause it. i uninstalled but it still wouldn't work... and i don't have that on my other PC

Thanks again

Matt

0

Do you have a program called 'Speedbit Video Accelerator' installed. If so get rid of that.
What you could do is uninstall the drivers and the teamspeak, reboot. Then install the drivers for the joystick, test first, if BSOD continues restart and try again. Or restart before you test it. Then if it works re-install the teamspeak software. What version of teamspeak do you have?

0

i think i might be getting somewhere with this. scanning other forums i came across a thread about the wingman force conflicting with the HID of the Zboard. these conflicts caused exactly the same problem as i have. i don't have a zboard, but i do have some other HID devices that could be conflicting.

i have already uninstalled my graphic tablet and the software, but the problem is still there. i am also going to try uninstalling my joystick and steering wheel to see if they are causing the problem. the possible causes are narrowed down by the fact that whatever is causing the problem has been used on both PCs. here is a list of devices that i use (or have used when this PC is down):

Logitech wireless keyboard/mouse (plugged in to PS/2 ports)
Logitech Attack 3 joystick (USB)
Logitech Driving force wheel (USB)
Tevion Graphic Tablet
Epson Stylus Photo R300 with Memory card reader (appears as a removable drive)
USB gamepad

i will add any other devices as i think of them

0

Look on Mses website. There was a hotfix a while ago to fix HID BSOD's in XP

do you know where it is? i've had a look around the MS knowledge base but i can't find anything

thanks

0

i cant seem to find it, i think it was one of the ones you have to request. (i got it with a graphics tablet). Hopefully it will be included in SP3

0

well i've managed to fix this. not entirely sure yet, but it was definitely down to one of the services, either the WIA service that runs with windows or the graphic tablet software that was running in the background (disabled it using 'software explorers' in C panel)

i'll do some experiments when i've finished playing to find out what service is causing this, and if i get the chance i will confirm it here

thanks for all the help given

Matt

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.