0

Hey everyone, first time here

I ahve a Canadian Toshiba M40 which has a corrupted "sptd.sys" file that's preventing the machine from booting into windows. I've gone to a couple places and a cople forums and they all say I need to reinstall windows, or somehow replace the file with an uncorrupted version, but I don't think I can do that unless I can get into windows. I have, as far as I know, a bootable Windows XP Home Edition CD in the drive, and I have, to the best of my knowledge, changed the boot order to check the CD drive first. A couple of problems here. First, the computer's internal CD drive is extremely finicky; basically, it decides when it wants to read CDs I put in it. Right now, it doesn't seem to want to. SO, the places I went to suggested I get an external DVD drive and try it through that, so I dropped a hundred bucks on one and it doesn't seem to work.

So basically, my questions are:

a) does anyone know if Toshiba M40 models can boot from external DVD drives?

b) does anyone have any other suggestions for what to do? A friend of mine has an Ubuntu boot CD... would it be worthwhile to try booting from that and then replacing the file that way?

2
Contributors
8
Replies
9
Views
9 Years
Discussion Span
Last Post by Suspishio
0

(a) They should be able to boot from external DVD drives if you've got the BIOS USB Legacy setting on. But I've never tried it so the answer's theoretical.

(b) If you can read the Ubuntu CD you can read the Windows CD although I appreciate that from your description the Windows CD might not hold up, whereas the Ubuntu CD won't be used much. So that's worth a try.

0

I've got the USB Legacy Emulation setting on, and the boot priority has FDD listed first. Still not doing it. Is there anything else I have to do? Press a button on start-up, do a dance, anything?

0

Upon further inspection FDD is not the setting it's supposed to be on, is it? The four choises are CD-ROM, FDD, HDD, and LAN. There's no USB... is there supposed to be?

0

Nothing doing yet, but thanks a lot for the help so far...

The BIOS option I have enabled is "USB-FDD Legacy." There isn't one that says "USB-CD-ROM." Maybe that means something...?

0

Nothing doing yet, but thanks a lot for the help so far...

The BIOS option I have enabled is "USB-FDD Legacy." There isn't one that says "USB-CD-ROM." Maybe that means something...?

You've got the correct setting. And it is directly referenced in the Microsoft KB article which I hope you've digested.

0

Yeah, OK, everything seems to be in order then. I guess the trouble is either with the CDs I'm using or it goes deeper than I've imagined.

0

I suspect you might have to physically take out the internal CD drive or at least DISABLE it in Device Manager.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.