0

Hello ya all.
I have a BIG problem with my XP Pro SP2.
Within last 48 hours I had to reinstall XP Pro several times (5 I think).

It all started with me borrowing USB HD and trying to transfer some files on it.

First, I get the message that a high speed device is connected on non-high speed port. It turns out to be USB 2.0 HD on USB 1.1 port. OK. It'll be slow.
Then, as I was downloading some stuff from the net, comp. rebooted it self (or rather tried to) displaying a message "Corrupted or missing C:\WINDOWS\SYSTEM32\CONFIG\SYSTEM".

Tried a safe mode - same thing.

Tried all of the f8 options - same thing over and over again.

Booted from Install CD.

Tried the -r option, and got the blue screen saying "IRQL_NOT_LESS_OR_EQUAL" following "0x0000000A (0xF000E987, 0x00000002, 0x00000001, 0x807FE4ED)"

Then tried to reinstall the whole thing and, after I pressed "F8-I Agree" (on the EULA screen) I got the same blue screen again.

Only solution at that point was to install OS on USB HD:

- First I disabled IDE HD in BIOS. All went well until the first reboot.
"Disk read error" it says. (BIOS has option for booting from USB)

- Booted from CD again and went with repair option.
Had to choose wich windows to log on - one on USB HD or one on IDE HD. Later one gave me the same ol' blue screen again, while the USB option worked.

- Finally, I was able to do SOMETHING, so I renamed the files in SYSTEM32\CONFIG dir (added .bad to ones without extention and those with .sav extention removed the "sav" part)

- Ran the chkdsk to find there were errors on disk. (fixed them)

- Rebooted to learn that those (previously *.sav) files were used during first installation process. (Comp. tried to continue the installation that was done last year)
Anyway, I had option of installing the XP once again.

- So I did. Formated HD (IDE one) and all that.

- installed SP2 and stuff.

I failed to mention that USB HD was unplugged all the time except during the system meltdown and my attempt to install XP on it.

All went well, that is, untill I tried to download somthing while USB HD was plugged in.

Yep.

Same thing happened again.

...the curses...

:mad:

And this time the USB HD wasn't even beeing used by system. (LED light was green, and it gets red when reading or writing)

Had to do everything all over again.

...the curses...

:mad:

Now I start to suspect that it has somthing to do with ethernet card.

Anyway, my spec. are

Processor - AMD Athlon Xp 1.6 GHz
MBO - Matsonic MS8137C+ (v2.0)
Memory - 768 MB (512 MB Gail and unknown 256 MB)
IDE HD - Maxtor 6E040L0 (40 GB) - 2 Partitions: 10 + 30 GB NTFS
USB HD - Toshiba MK1031GAS (from the device manager) 100 GB Single partition NTFS
USB - VIA Rev 5 or later USB Universal Host Controller (x2)
Network - Realtek RTL8139 Family PCI Fast Ethernet NIC
Display - Radeon 9200
Chipset - Cann't tell. The heat sink is, kind of, blocking the view, and device manager says only "VIA Bus Master Controller".
Sound - VIA AC'97 Enhanced Audio Controller
Optical - Pioneer 110D
Internet connection - via network card (all settings are default except EAP is SecureW2.2)
Plus mouse, monitor and keyboard.

I'm not sure if it is compatibility issue between USB HD vs. USB Controller, USB HD vs. Network adapter or whatever.

If anyone can give me a clue, please reply.

4
Contributors
7
Replies
8
Views
11 Years
Discussion Span
Last Post by dcc
0

I have had the exact same problem twice. I would be interested to hear how you eventually resolved this problem. I had to reinstall XP as well as nothing else worked.

0

Well, I haven't solved it.

The thing is, USB drive and PC in question are not a "permanent combination". USB drive is my friend's and PC is my borther's. I still havent figured out what went wrong there.

0

Well, I haven't solved it.

The thing is, USB drive and PC in question are not a "permanent combination". USB drive is my friend's and PC is my borther's. I still havent figured out what went wrong there.

It may be possible that there is some problem in the USB drive since you said that when you installed XP while selecting USB drive and after the first boot it said error reading the drive. I would suggest get the USB drive replaced. Try to perform clean install on the hardddrive and in that you have to delete the existing partitions and recreate partition and format the hard drive using NTFS file system using the regular format (not the quick format).

0

For me, they are thing of the past, because I'm not using neither my bro's PC nor that USB drive, which I borrowed from a friend of mine.

Problem with booting from the USB drive, I think can be assigned to the outdated motherboard (USB 1.1 only), and not to the USB drive, which performs flawlessly on my PC and my friends PC.

For your sake, (you are still having that problem, right?), this is what I know:

Registry gets corrupted when the drive is connected and when there is a heavy network activity, rendering PC unbootable from IDE HD and setup CD. There is a trick to bypass the registry checking procedure (which crashes the system) when booting from setup CD (disabling IDE HD via BIOS), but that would exclude the "repair windows installation" choice. You would be forced to reinstall the windows. No formating needed, since it is not HD failure/corruption, but simple file corruption (software-generated).

0

The borrowed hdd may have drivers from the other installation which is confusing your hdd and as a result corrupting your registry.

0

Only drivers in action were USB (1.1) root Hub drivers. There are no HD-specific drivers.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.