0

My Linux machine is running Fedora 10, Apache 2, PHP 5, MySQL, and VSFTPD. I don't want the public to have access to my FTP files. All I want is to be able to securely connect my Windows machine using Aptana Studio and be able to easily transfer my web files to my server machine.

Could someone explain to me how I would go about setting this up? Right now I cannot even get Aptana to connect to my server.

2
Contributors
5
Replies
6
Views
7 Years
Discussion Span
Last Post by freshfitz
0

Is ftp running try: /etc/init.d/vsftpd start
Is iptables blocking port 21 try: /etc/init.d/iptables stop
Have you tried connecting with a regular ftp client by default root cannot ftp into vsftp so you have to try anonymous or create a new user.
Look in /etc/vsftpd.conf to turn off anonymous access but try to connect first and get ftp working

0

I tried all of that. And when I type 'service vsftpd status' it says that it is running. I have opened ports 20 and 21, and set vsftpd to use port 21. When I try to do this in Aptana, it won't connect. When I go to my other computer and type in "ftp://www.mysitename.com/" it brings nothing up, but on my server when I type that into my address bar it shows the FTP index. I think it is something to do with it only allowing FTP locally. Do you know how to fix this?

0

No it sounds like a firewall issue. Is this box behind a firewall? Is iptables running?

0

I edited iptables so that it would open 20-22. I think I found the problem. I forgot to open the ports on my router. Let me try that.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.