I've just installed ubuntu 10.10 LTS and it is giving me an error that it can't update packages because this version isn't supported anymore.
Is there a way of fixing that? If not, I think I'm downgrading to ubuntu 10.4 which will be supported until April 2013. It sucks that we're kinda pushed to use 11.04 and above. In my opinoin, unity sucks badly and slows my machine.