0

I tried to run ./configure on a small program that the Linux book I'M reading instructed me to download and I got the error "no acceptable C compiler found in $PATH" I then tried to run atp-get install gcc, but then I got "unable to locate package gcc". Any dieas?

3
Contributors
3
Replies
20
Views
4 Years
Discussion Span
Last Post by naphets
1

Try to install build-essential (at least, in Ubuntu repos, I don't know if other debian distros have it too), it will install everything you need.

$ sudo apt-get install build-essential

Also, if you get the message "unable to locate package ..", then you should try to do a search for it:

$ sudo aptitude search gcc

It should list all packages that contain that word (like grep). It's possible that the package is named something else, like gcc-4.7 or something like that.

0

Thanks. It worked but it took me a while. I had to run apt-get update first. I alwasy forget that after I've just installed a new server. Since we're on the subject, why do simple apt-get commands not work until upate has been run?

0

apt-get update , Updates the "local database" of what is available (in the Terabtytes) on the clouds...
sudo apt-get install build-essential libc6-dev libbz2-dev check
Ubuntu lacks the above by default

Edited by naphets

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.