0

I have Windows 7 Ultimate installed, then installed most recent version of Debian on an unallocated 100GB partition on the primary drive (on a PC, not on a notebook). That all works without a problem. The problem is that I can not figure out how to change the boot menu to boot with either operating system. I downloaded ezBCD.exe and edited the boot menu to add the Debian os, but when I select it after rebooting I get the error that Windows cannot boot because the files are corrupt (there's lots of other info too that I have forgotten).

When I installed Debian I told it to install grub in the primary boot sector, where I think that is where MS-Windows boot loader is installed.

The only way I can boot into Debian is to use the boot menu of the motherboard bios setup.

Any suggestions how to make the duel-boot menu work?

Thanks

Edited by Ancient Dragon

6
Contributors
9
Replies
51
Views
4 Years
Discussion Span
Last Post by Ancient Dragon
0

I think windows boot loader is replaced by GNU's boot loader.

This might be of some help. Although it was for Ubuntu, but I hope it will also work for Debian.

0

Debian uses grub2, which is a real pita to reconfigure, though it is possible. Do you get the grub splash screen when it is booting? If so, then what happens when you hit the spacebar before Windows (or whatever) boots up? Usually you have only a couple of seconds to do that (it should show the boot menu with the installed systems displayed), though that can be reconfigured as well.

0

I didn't get the grub screen until I used ezBCD.exe to add Debian to the menu. I never saw the screen that Debian installed. Windows is the default boot item in the menu, so I used arrow key to change to Debian and hit Enter key. It is at that point I get a bunch of error messages saying that Windows can't start.

0

I just installed Debian 7.0 in a virtual machine, and dealing with grub2 is just such a PITA! The original grub (which fortunately RHEL still uses) was SO much simpler to deal with. I'm still trying to figure out how to deal with grub2. I did some such successfully a year or two ago when I was running Ubuntu on my laptop, but I dropped that in favor of Scientific Linux when Ubuntu stopped supporting my wireless cruft out-of-the-box. Yes, with SL/RHEL I still have to manually install the drivers and such, but it works, and I don't have to futz with grub2... :-(

0

I see from google that Ubuntu has used grub2 since version 9 so Ubuntu will have the same problem.

Edited by Ancient Dragon

1

First install windows 7 on first partition or /dev/sda1
then istall your Debian Linux
grub will auto detect your windows

0

In bcdedit go on deployment and there is an option to reinstall the MBR. after that the windows bootloader will come first giving you the option to choose either windows or Linux.

By choosing linux you get grub which gives you an option to choose windows or linux which is a pain in the ass :P So just go to Linux and in the terminal navigate to:
/boot/grub
and edit
grub conf to have a timeout of 0

0

grub will auto detect your windows

I tried that -- grub didn't detect any operating system on the computer.

Did you find solution?

Nope -- I gave up. Your suggestion didn't fix the problem.

Edited by Ancient Dragon

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.