0

Hello all! i installed Ubuntu OS alongside Windows XP, but i got screen resolution problem, i mean everything was out of the monitor screen, was may be 800x600, i tried to adjust it through ubuntu's GUI Appearence feature but not succeeded, i guessed that i probably need separate VGA drivers for ubuntu, am i right? if so then how to fix this problem? Thanks !

4
Contributors
4
Replies
58
Views
3 Years
Discussion Span
Last Post by hbutt875
1

I assume you are using a dual-boot capability from your post. What video hardware does your system have? You need the appropriate drivers. By default, Ubuntu will not install proprietary video drivers, but there is a System (possibly in Preferences) entry that will provide the ability to install the appropriate drivers for your video, giving you full resolution capabilities. If your Linux distribution cannot handle your specific hardware, then it will revert to the VESA api's that most all hardware supports, but that has limited resolution as you have seen. VGA drivers? Those would be limited to 800x600 which you already have. VESA would provide higher resolution, but not suitable for video streams.

0

hi rubberman, thanks for the help!yes i installed it in dual boot mode, and all drivers are working fine in windows XP, i did not get any message to choose or adjust resolution while installing ubuntu 12.04, i am on another system right now, and don't know whats VGA drivers or hardware are on that system where is installed it.But i remember in Ubuntu's Appearence>display, there was only one resolution option ie 800x600.So what you recommend what to do now?

1

Did you try to query and change the screen resolution with the xrandr command ? See this blog entry for example. If a command line with xrandr works, you could perhaps add a script at startup to execute this command line.

1

For driver Issue: Go to dash and search for "additional drivers" and open additional drivers.Wait for a minute (you need an active internet connection).If any VGA or display driver available install it and reboot your PC.
For setting issue: go to system settings and open "Displays".Now change the resolution. Good luck.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.