0

I recently purchased Terra-Master F4-220 but I can not sign in via ssh. I thing is I don't think it's on the TM end, I think it's on my debian server's end. When I do try and connect this is what I get.

$ssh root@192.168.1.2
/etc/ssh/ssh_config: line 55: Bad configuration option: permitrootlogin
/etc/ssh/ssh_config: line 55: Bad configuration option: allowusers
/etc/ssh/ssh_config: terminating, 2 bad configuration options

Here is a sample of the tail end of the /etc/ssh/ssh_config file.

PermitRootLogin yes
AllowUsers root garrett media plex rsync

Any ideas as to what the problem could be. I purchased the TM becaue I thought it would be easier to maintain my movies and tv shows media server than the headless debian server I built and am currently using. The TM can install Plex and DLNA with just a click. All I am trying to do is copy the movies files currently store on my debian server to the TM. Thanks for any help.

2
Contributors
1
Reply
10
Views
3 Months
Discussion Span
Last Post by rproffitt
0

Blatent copy from link below:

TL;DR The line PermitRootLogin yes does not belong in the ssh_config file, only in the sshd_config file.

The file ssh_config describes the configuration options for the client. As the error logs say, there is no such option PermitRootLogin for the client. The sshd_config file however, describes the options for the daemon. (You can recognise this because of sshd) The server/daemon does have a PermitRootLogin option, so it belongs there.
From https://superuser.com/questions/908179/ubuntu-plesk-ssh-issues-permitrootlogin

Probably same issue for line 2.

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.