So I get the error CPU has been disabled by guest os. Power off or restart. But if I power off, it shuts down. I wana run it. Then error again...

I tryed:
- Disabled all unnecessary hardware.
- Turned off USB Legacy support in BIOS.
- Found no explicit CPU virtualization setting in BIOS...
- Messed with every setting of the virtual machine.
- cpuid.1.eax = "0000:0000:0000:0001:0000:0110:1010:0101" stuff. Then everything again.
- Tryed this with 5 preinstalled VMware osx. (10.5; 10.6; 10.7)
- Also tryed to install 3 osx to another hdd without virtualization. Those are also not working.
- I'm pissed!

Now what else?!

Thanks for any help!

Recommended Answers

All 5 Replies

Yes, this is the CPUid mask, I've already tried. On some versions this makes a difference, some error shows up with CPU state, and after that the same message. But the error is always the same.
Also this thread is about an issue with 10.6.3, but I've also tryed 10.6.7; 10.5.x; 10.4.x OSes, and no difference.

CPU virtualization thingy is grey in the bios, but Enabled, so there should be no problem around this.

On some versions when applying the CPU mask, I get kernel panic instead. They are still not working thogh.

Try uninstalling the app totally and reinstall it again. If that does not work, i am sorry i could not help you with your problem.

Be a part of the DaniWeb community

We're a friendly, industry-focused community of developers, IT pros, digital marketers, and technology enthusiasts meeting, networking, learning, and sharing knowledge.