I'm having some weird issues with my Powerbook G4 ( "PowerBook5,7", "PowerPC G4 (1.2)") connecting to my Airport Express at home. A few weeks ago I installed my brand new Airport Express at home and made a WPA Personal security password as recommended. Everything worked fine for a few days until one day my computer suddenly seemed to not find the signals anymore.
I tried all types of problemsolving from the book, but nothing seemed to help.
What confuses me is that my roommate (who also has a PowerBook G4, "PowerBook5,7" "PowerPC G4 (1.2)") has no problems connecting.. she gets the signals fine!!??
THEN, I reset my A.Express for open access again and got back on.. for a few days.
Then I suddenly lost all traces of the signals again!!?? My roomate is still happy going and my computer picks up all other signals from the neighborhood.
How can this be? I did nothing but turn my computer on and off and suddenly all signals are non traceable any longer..
I hope someone can help me, I am as you probably can see from my request not a computer literate exactly..
And Ps..
My G4 was bought in the U.S and my roomate's in Norway. On her computer the first security setting came up as a "WPA Personal" but my computer called the same one a "WPA2 Personal".. any hidden clues in this?
I have tried erasing all network history to let the computer search for new connections also, but all it picks up on again is my neighbors...

WPA2 is a newer version of WPA, and it does have some compatibilityissues.
What are the exact versions of the OS on each computer, and what is the exact version (including revision #) of the Airport/Airport firmware?

Thank you for replying!

My roomate's OS is 10.4.5 and mine is 10.4.6

AirPort Card information:

My Roomate's says:

Wireless Card Type: AirPort Extreme
Wireless Card Locale: International
Wireless Card Firmware Version: 402.6 (
Current Wireless Network: Apple Network 709861
Wireless Channel: 13

Mine says:

Wireless Card Type: AirPort Extreme
Wireless Card Locale: USA
Wireless Card Firmware Version: 404.2 (
Current Wireless Network: wireless network not available

Hope this is what you are asking for! If not please guide me to where I'll find what you're after!


Can you access unencrypted networks? Try that (if you have an unencrypted one around ;)). Your Airport drivers may also be messed up. I have a friend who messed up his Airport drivers. Unfortunately, the only way I know to recover airport drivers is to do a reinstall of Tiger.

Be a part of the DaniWeb community

We're a friendly, industry-focused community of developers, IT pros, digital marketers, and technology enthusiasts meeting, networking, learning, and sharing knowledge.