I just bought a new 15 inch Macbook pro yesterday and I am trying to install windows using bootcamp assistant. I've done all the software updates but when I go to do the firmware update it says that i do not need this update. I am sure that it is the right one since I called apple about it. However, apple will not provide support any further for bootcamp. I figured since i don't need the firmware update, it must've come updated. So I tried opening bootcamp assistant but it says it cannot run the program b/c the firmware needs to be updated. I have tried reformatting my hard disk and starting from scratch, following instructions to the letter, but it does the same thing. PLEASE HELP!!!:eek:

OK, you used Software Update, right? (You can access it from the Apple menu). Click update, and it should update everything that needs updating, including firmware updates.

You should check the firmware version. Choose Apple menu -> About this Mac. It should say 10.4.7. Earilier versions will not work.

Did the software update fail, and you still don't have the 10.4.7 update? Head over to Apple's site to manually download and install the update:


I have the exact same problem.
My firmware is up to date! Everything I have is up to date!
What could be the problem?